Troubles with login and suggestion

I finally was able to login to the forums, after fighting with the “system” for two days. I just migrated from Ubuntu 20.04 (too many changes made working very difficult) to OpenSUSE Leap, and I hope the same changes don’t show up on this version of Linux - I use Gnome Classic and have it set up so I can work, do research, and ‘play’ with Amateur radio when I have that rarity - spare time. The problems I encountered after the change (they don’t really even support Gnome Flashback - the same as Gnome Classic here, and it’s very different and difficult to work with).

info for mods: (may indicate a problem on either end or in between) I was able to register and get into my profile page no problem, but nothing I did could do (until a few minutes ago) could get me into the forums. I tried resetting the password, and got a reset email within a minute - changed the password, but then the ‘system’ rejected the change and said that the token had expired. I barely even had time to type in a new one and then re-type it - it expired before I could finish (and I type fast). I tried emailing for help, but every email I tried sending was rejected because I wasn’t a forum member. Finally I clicked on a link that seemed different, and the reset of my password worked (I copied-and-pasted the token in, but the page rejected the change and said the token had expired. Then I tried clicking on the link in the email (second one) and this time it took.

May I suggest that the page have a clear email or “message us” link that doesn’t require being a forum member at the bottom of the page (I don’t see anything like that on my system - using Firefox). Also, please check the timeout limitation - sometimes emails take a while to arrive (10-15 minutes is normal) and timing out in less than a minute is too short.

Thanks for ‘listening’ - I’m looking forward to using OpenSUSE!


I guess from your story above, that it is not your Ubuntu experiences that you want to discuss here, but your experiences with logging in and changing the password.

As I can not detect all the different steps you did, I can not deliver much comment on your problems while trying to register and log in. Apart from the fact that most other people seem to do this without reporting problems.

About changing your password, I can point you to the main page of the forums where you will see at the top right a section: Security info, followed by the text" Need to change your password or email address? …

I was able to resolve the login problems. I was trying to be helpful by mentioning some of the difficulties I had with the process… in case someone would want to check the registration/login system (telling my observations, which might help point out potential issues). What I was trying to indicate is that it seems that I encountered two different ‘change password’ pages or that they were not consistent in how they operated.

I thought it might help by mentioning why I was starting with OpenSUSE.

Anyway, that’s fixed. I’ve got other questions to ask…

Thanks for the reply!

It may be of interest to you to mention a few things that may explain more clearly what you see.

The openSUSE forums use vBulletin as software. But the login features of vBulletin are not used. There is a central login facility used by more openSUSE (and even SUSE) sites, like the Bugzilla. Thus you can use your credentials on those sites also and you even might find yourself already logged in in the Bugzilla when you are already in the forums. The result of this is that the “normal” change password functionality of the vBulletin forums does not work as you might think. BTW the positive side of this is that when some years ago vBulletin had a security vulnerability which allowed hackers to steal the credentials, openSUSE was not involved at all.

While we tryto draw attention to our password/e-mail address change functionality with e.g. the text in the main page and also in our T&C, this might not be adequate, special for people that worked with vBulletin based forums earlier and thus go for a known procedure rather then looking for some documentation.

In any case, we are looking for a replacement software and will not put much effort in changing the present situation.

Hope you enjoy openSUSE.