Troubles setting up Samaba

I’m not having success setting up a network using Samba.

In Samba I’ve done the following:
Startup at boot, open port in firewall
Shares: added a folder, added the option “guest ok” yes
Identity: workgroup, not a DC
WINS: Remote WINS Server, Retrieve WINS server via DHCP
Trusted Domains (blank)
LDAP settings (bland)

Firewall Allowed Services:
Netbios Server
Samba Client
Samba Server

Firewall Interfaces:
Wireless Network External Zone

Any help would be appreciated.

Hi Parthenolide,

We may need more information to be able to help you further:

  1. What is your version of openSUSE?
  2. What is your version of Samba?
  3. What is the path on the server of the share you added to Samba?
  4. How did you access the share?
  5. What did you expect?
  6. What occurred instead?

Note that AppArmor may block Samba access to shares. If you use AppArmor, you should try to put the /usr/sbin/smbd profile in complain mode.

Open SuSE 13.1 64B
Desktop Kernel 3.11.10-11.1
Samba 4.1.6-3.18.1
Path added: /home/username/share
Tried accessing the share with the server computer. I can see the workgroup. It times out with opening workgroup to find the share folder.
Tried accessing the share with a different computer. It cannot see the workgroup.

(Looks like the versions of the kernel and samba are old.)