Trouble with Wine x64

Hi. I installed Wine and tried to run Braid game on a laptop with openSUSE 11.3 x64. It throws me the message:

Trying to load PE image for unsupported architecture (AMD-64)
err:seh:raise_exception Exception frame is not in stack limits => unable to dispatch exception.

Which means Wine x64 is not able to run 32 bit apps, and I imagined it. I installed Wine through Yast, selecting the packages Wine, Wine32, Wine-Gecko and Wine-mp3. So I suppose Wine x86 was also installed for running 32 bit apps. How can I run them then? Tried with “wine32 nameoftheapp.exe” and didn’t work… Thanks.

Any help? Thanks.

System specs:
Laptop Dell Inspiron 1520
Intel Core 2 Duo T7700 2.4 GHz
Nvidia GeForce 8600M GT 256 Mb (drivers up to 260.19)
openSUSE 11.3 x64

Have you tried installing PlayOnLinux?

A google on “err:seh:raise_exception Exception frame is not in stack limits =>
unable to dispatch exception.” gives lots of hits, but i think it’s a
question for the wine forums…

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.3 (x86_64) Kernel
up 1 day 20:21, 2 users, load average: 0.08, 0.06, 0.04
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.12

On 11.1 x86_64 I have wine 1.1.9-i586 from update repo running OK.