Trouble with Skype 2.2 Beta for Linux on Suse11.4 64bit


Suse11.4 (Celadon)
Kernel Linux
Gnome 2.32.1

I’ve just followed the instructions at SDB:Skype - openSUSE again, as before. The install didn’t start automatically when the download finished so I used package installer. Skype appears to start normally, before promptly closing itself after about 3-5 seconds. When running it from terminal, I get the message:

Inconsistency detected by dl-open.c: 582: _dl_open: Assertion `_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT’ failed!

Code: rpm -q libasound2-32bit xorg-x11-libXv-32bit xorg-x11-libs-32bit libqt4-x11-32bit libpng12-0-32bit skype

Returns: libasound2-32bit-

Code: zypper lr -d

Returns: # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
1 | Non-OSS | Non-OSS | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/non-oss |
2 | OSS | OSS | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/oss |
3 | Update | Update | Yes | Yes | 99 | rpm-md | Index of /update/11.4

Anyone have ideas?

try these commands with root permissions and your pc connected to the internet:

rpm -e skype
zypper ar skype1
# note there is a space between /openSUSE_11.4/ and skype1 in previous line
zypper in skype
zypper rr skype1

and see if that works any better.

That last command is very important.

Also, if you are going to start a new thread on a problem in an old thread, please advise those who are participating in the old thread. Its not consider proper forum etiquette to have more than one thread going on for a problem.

try this:
vi /usr/share/applications/skype.desktop
add that:
Exec=LD_PRELOAD=/usr/lib/libv4l/ /usr/bin/skype

An explanation of alpha080’s post … that is intended for users who typically have a gspca compatible webcam. Its likely NOT for users with a uvc compatible webcam.

skins345669, what can you tell us about your webcam? With webcam connected, run this command and post here the output:


lsusb returned: Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0bda:8197 Realtek Semiconductor Corp. RTL8187B Wireless Adapter
Bus 005 Device 002: ID 04f2:b070 Chicony Electronics Co., Ltd
Bus 003 Device 002: ID 046d:c521 Logitech, Inc. Cordless Mouse Receiver

Besides that, I followed the instructions given and am still having the same error message returned

ok, thats your webcam. What is important there is “04f2:b070”.

If one then goes to this wiki page: HCL:Web cameras - openSUSE you will note it recommends you check uvc driver wiki page to see if your webcam is supported by the ‘uvc’ webcam driver. (IMHO uvc compatible webcams are the easiest to use in GNU/Linux).

And that page has this to say:

04f2:b070Toshiba Satellite L350D notebooksChicony Electronics

indicating your webcam is a UVC compatible webcam.

Hence the

Exec=LD_PRELOAD=/usr/lib/libv4l/ /usr/bin/skypeExec=LD_PRELOAD=/usr/lib/libv4l/ /usr/bin/skype

code is not appropriate as it is intended for a gspca compatible webcam which yours, being a ‘uvc’ is not a ‘gspca’.

Did you try my recommendation (with root permissions) ?

rpm -e skype
zypper ar skype1
# note there is a space between /openSUSE_11.4/ and skype1 in previous line
zypper in skype
zypper rr skype1

Yes, followed those and got the same error message.

I’m still puzzled over why this message has appeared for you. Did you previous try using gtalk ? (ie the google video chat). I ask that because I have read of this problem originating because of an attempt with gtalk (and I don’t know the solution there) but I have never read of it before originating from Skype.

I have had the same exact problem with skype 2.2 since it was released. Rather than battle with it, I just use the previous version.

Very sensible. Can’t find the RPM though, would you mind sharing a link?

I have version 2.2 on 4 PCs and don’t have the problem.

When I look at Download openSUSE 11.4 I do not see any earlier version (all packagers have version Where did you obtain the previous version from ?

Ahh … my memory is coming back now. I think this is a bug that bit a number of Linux Skype users. There is a work around and it involves either putting in place, or removing, an xml file from somewhere.

I need to look at my notes on this when I get home. In the mean time, if in a hurry, perhaps try google searching on “skype linux bug xml” or something like that.

Since the bug never bit me, I never paid much attention to it. Sorry.

Possibly try something like this:

rm -r  ~/.Skype/shared.xml

and maybe if that does not work consider

rm -rf  ~/.Skype/shared.xml

but I get quesy when ever the ‘f’ option is used with rm so I am not convinced that latter command is good.

I’m in a rush and don’t have time to look at this in detail.

Any solution is good so thank you very much.

I have tried all of the xml related fixes out there, even deleting the existing one.

None worked for me.

The solution is pretty smple, use version 2.1. It works…if it ain’t broke don’t fix it. :wink:

Except … where does one find the rpm for 2.1 ?

I still have it, you can get it below.

I just want to add another option, since I tried that today with success, but
please try first the advise of the others:
I installed the skype rpm for openSUSE directly from
to see if that works ( it is a i586 rpm but I installed it on 64bit).
As usual I had to figure out some dependencies it needs which are not automatically

sudo zypper in libpng12-0-32bit libqt4-x11-32bit libqt4-32bit

after that

sudo zypper in skype-

and the result works (including my webcam, my knowledge is not deep enough to say
if there is an essential difference to your webcam).

PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.4 | GeForce 9600 GT | 4GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.4 | nVidia ION | 3GB Ram

I still have it, you can get it below.…-suse.i586.rpm

It was all going so well and then this:

Inconsistency detected by dl-open.c: 582: _dl_open: Assertion `_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT' failed!

On 06/20/2011 10:36 PM, skins345669 wrote:
> Inconsistency detected by dl-open.c: 582: _dl_open: Assertion `_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT’ failed!

this is a good one!!

first: where are you seeing this error?

second: if you use YaST to add a new test user, then log in as that test
user and give Skype a try–does it still error out and die?

third: describe your hardware, please…

fourth: after some casual reading <> i suggest:

  1. if you are one of those folks that never boots (instead lets it run
    or always hibernate or sleep) then, shutdown completely and do a
    complete boot from power off…and try Skype again…if it works,
    yipee! if not continue:

  2. yours may be a graphics driver problem, if your graphics is ATI
    or nVidia and you are not running their proprietary driver, try
    working your way though doing that…start here:

  3. if not the above then i believe yours may be a memory problem…the
    way Linux uses memory is famous for ‘finding’ problems that other
    systems don’t (you didn’t mention so i assume you may be relatively
    new to Linux?)…boot from the openSUSE install CD or DVD you used to
    install, and do this:

if that returns no errors, then boot again from that disk and this time
pick “Memory Test” at the bottom of the list…

this is important: let it run at least over night (and i don’t mean go
to bed at midnight and jump up at 5 in the morning to see if all is
swell!)…you have not said how much RAM you have (or i overlooked it)
if you have 1 GB let it run at least 12 hours, and if you have more, let
it run more…

it may take many many “passes” to find the offending bit causing the
“Inconsistency” to be “detected”…

any memtest error is FAR too many…fix the hardware problem and i
think this “Inconsistency” will be history…

and, by the way, it may be a corner case kernel problem…

if 1, 2 and 3 don’t get you smiling please post again…(or do more
casual reading from the google cited…)

as always, Have a lot of fun.