trouble with my graphics card (linux noob)

hi all, i have just been getting used to opensuse 11.1 (needed it for programming on netbeans for university)

so far i have been quite impressed with the layout and functionality of linux, i have sorted afew issues out myself (drivers for network, sound card etc.), but there is one thing i just cant get my head round and that is the graphics driver.

i have an ati radeon 4870, so i have tried to install catalyst off the amd site (it didnt work), tried getting the radeon tool (from this site) and im still at a dead end. for instance when i install through YAST i can never find the program it installed. and when i do it through the terminal it gives up half way through the installation

one of my main problems is that im not very clued up on the functionality of linux, i have read that there is known problems with ati graphics cards and linux, but i cant seem to sort it out by myself.

has anyone else had similar problems?

apologies in advance for my noobish knowledge of linux

This may help, yes?. ATI - openSUSE

Sorry, can’t offer much help on ATi issues. I always use nvidia which currently is lightyears away from ATi’s drivers

thanks for the quick reply, i tried those steps (i should mentioned this in my first post) and the part where i have to enter the code:

init 3
SaX2 -r -m 0=fglrx

terminal returns a message saying they are already system files
(‘Program ‘init’ is present in package ‘sysvinit’, which is installed on your system.’)

basically i do not get the result from that guide. am i doing something wrong?


that’s very odd that you get such message so you really must be doing something.
Try this:

  • hit CTRL+ALT+F1
  • login there as root user (root -> root’s passwd)
  • type init 3
  • execute the SaX command above
  • reboot system


When you ran the .run file from ATI’s site, and entered

aticonfig --initial

, and rebooted, what was in your /usr/share/ati/fgrlx-install.log file?

Just FYI, ATI’s installation notes advise against running sax2.

I have been running fglrx drivers with no problems on my AMD64 box with a radeon 2600 board. I see 4200fps from glxgears.

Hope this helps.

microchip8: i try those commands and terminal just tells me they are already installed on the system.

i type:

init 3

(hit return)

and it just tells me the command and its presence on the system.

tcubed_bus: contents of that file are as follows:

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Error] Kernel Module : Kernel module build environment not found - please consult readme.

im guessing this means there was an error, or the file is empty from the installation?

regards, alex

this is very odd that it tells you such things when you type init 3. I’ve never seen such a thing. You can however reboot and at the boot screen, in the options bar, type 3 - yes, just 3 and it’ll take you to runlevel 3

as for the build environment, you need to install the kernel sources and gcc/make, etc basically the basic build environment. In yast, when you switch to patterns, you can select it there (kernel development or similar, can’t recall atm as I don’t use patterns)

ATI actually does a pretty good job of describing the prerequisites for an fglrx installation. The same web site with the drivers has the installation notes.

I have all the required software, so I just get in the .run file, run it, accept all the defaults, do aticonfig --initial, and reboot. No sax2.

It has worked fine for the past 7 versions of fglrx.


I met with the same problem, the ati driver file I use is, OS is CentOS 5.5, the problem solved finally: must ensure the following things are installed:
gcc “uname -r” to get the accurate version of the kernel, like the OS of mine, the result is “2.6.18-194.el5”
3.install the accurate version of the kernel header files, which commonly be included in “kernel-devel” package, like OS of mine,it would be “kernel-header-2.6.18-194.el5.i686.rpm”, the slightly newer or older versions cannot be done!(like mine, the package installed by yum online is newer -“kernel-header-2.6.18-194.11.1.el5.i686.rpm”, which I replaced finally with the older one on my system installation DVD) must ensure that the directory “/lib/modules/`uname -r`/build” directs to the directory that contains the kernel header files, like mine, it’s “/usr/src/kernels/2.6.18-194.el5-i686”, if not, you should make a link to it. After that, it should be done. Good luck.

You can start the computer in run level 3 from boot.
Reboot your pc
At the grub boot menu, type 3 and then enter.
This will take you to a console login where you can login as root.
Navigate to the directory where you downloaded the ati binay and run:
sh ./ati-insta…