Trouble with first boot after installation

Hi!
I have tried several different distributions of Linux, with no luck so far after several days of trial and error. OpenSUSE is my latest attempt, and I have some of the same trouble. I get ACPI errors at the first boot after installation, which is something I have got on the other distributions as well. I therefore select ‘e’, and add acpi=off as a boot option, and those errors are no more. Good! But, when the openSUSE load screen comes up, it halts at the last one of the three green dots, and stays there. I have also tried with the recovery mode startup, where more of the screen output is shown, and it then halts at the following message:
A start job is running for dev-disk-by\x2duuid-f35297db\x2d…35\x2d4f75\x2d9ad5c86a0111.device

I got USB errors when I tried Debian, which wouldn’t boot either. Could it be something similar going on behind the curtain here? The computer is a workstation with brand new hardware, and I suspect it could be a part of the problem.

I would be very grateful for answers!

When booting, during those three dots, you can hit the Esc key and see what happens and where it got stuck.

And about that “start job is running”, is there any mass-storage device you have connected during installation but not now anymore?

Welcome to the openSUSE forums! “Brand new” means nothing to us, please describe in detail, at least processor type and/or graphics unit is needed to look for possible workarounds.
Also, you may need a newer kernel for “brand new” processors, try one of the Tumbleweed Live DVDs (no need to install) to test if that might be the problem.

Thanks for your replies!

I actually wasn’t able to hit esc during the load screen, nothing happened.
I haven’t added or removed any mass storage devices after the installation.

System info:
Mainboard: ASUS PRIME TRX40-PRO
CPU: AMD Ryzen Threadripper 3970X
Memory: 8x Kingston KHX3200C18D4/16G
GPU: Nvidia GeForce RTX 2070 Super

Possibly everything is OK except for, the GPU.

  • If AMD then, if Linux then, also an AMD GPU …

3970X needs the mce=off boot parameter until a patch from AMD reaches the official kernel.
Details here: AMD Ryzen Threadripper 3970X / 3960X Linux Benchmarks Review - Phoronix
and here: [PATCH] x86/mce/AMD: Allow Reserved types to be overwritten in smca_banks[] - Yazen Ghannam

Said patch should be included in kernel 5.5.3 according to this: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/log/arch/x86/kernel/cpu/mce/amd.c?h=v5.5.3
So current Tumbleweed still needs the mce=off option; but kernel 5.5.3 should be in Tumbleweed in a matter of weeks…
You may try the bleeding edge kernel available here: http://download.opensuse.org/repositories/Kernel:/HEAD/standard/x86_64/
but please be aware that kernel HEAD is still experimental.

Thanks a lot for your insights.

I tried the install I have already done (Leap 15.1) with mce=off, but it still halts at the load screen. Then I tried the Tumbleweed Live iso from here: https://software.opensuse.org/distributions/tumbleweed
Tried to run the iso without installing, with mce=off, but it still freezes at the same spot.
I have also tried Ubuntu 19.10 just now, and there I get a stop with almost the same errors I had with Debian 10.2:
usb 7-6: Product: USB Audio
usb 7-6: Manufacturer: Generic

In Debian they were:
[7.356207] usb 7-6: cannot get ctl value: req = 0x83, wValue = 0xc00, wIndex = 0x1300, type 4
[7.356251] usb 7-6: 19:0: cannot get min/max values for control 12 (id 19)

Could these be lurking behind the openSUSE freeze as well?
I find these errors funny, as I don’t have any sound card installed in any USB ports.
If I try to run the Ubuntu installer with acpi=off and mce=off I get initramfs error, with the ‘no live medium’ message.

This is a machine at work, and I weren’t much involved with the picking of hardware. Installing Linux has been such a mess, but I hope it is possible to get working somehow.

Yes, but, the Mainboard has 8-Channel HD Audio – which, internally, is on the board’s USB.
[HR][/HR]Could it be that, the UEFI/BIOS needs to be setup to suit Linux?

  • Windows 10 default is for a single-disk RAID – you may have to disable this and a few other Microsoft specific things as well.

You may have problems with the graphics card as well, since most work on the opensource nouveau driver is still in progress for the Turing aka NV164 chips: https://nouveau.freedesktop.org/wiki/FeatureMatrix/
Let’s try something very basic: boot with the “mce=off nomodeset 3” boot options and see if you get at least a command line login.
If so, try “mce=off nomodeset” and you should get a minimal GUI; if so, you might be able to proceed with the install, then try to install the Nvidia driver following this page: https://en.opensuse.org/SDB:NVIDIA_drivers

The following should be helpful specifically for boot options…
https://www.kernel.org/doc/html/latest/x86/x86_64/boot-options.html

Besides mce=off,
Others might be required as well, specifically

mce=no_cmci

Also,
Shortly (within a month?)
TW might be getting the 5.6 kernel(Merge Close which is finalization of what is accepted just happened) which is supposed to be introducing an enormous number of new “stuff” of all types… I’d guess that latest support for AMD CPUs is in the list.

TSU

This did it!
I was able to get into the simple GUI, and install the GPU drivers through Yast. Now I don’t even have to put ‘mce=off’ as a boot option to get started - which is maybe a bit weird considering I’m still running Leap 15.1? Anyway, I don’t care - it works. Big thanks to all of you!

Nice to read you are up and running. As to the mce option, chances are that the installer saved it for you.
To see the current boot command line open a terminal and issue, for instance, the following:

dmesg | grep BOOT

and see if the mce=off is there…

@McDynam:

You can also view the current boot command from a CLI by entering the following command: “cat /proc/cmdline”.

I have the following boot commands:

BOOT_IMAGE=/boot/vmlinuz-4.12.14-lp151.28.36-default root=UUID=f35297db-2f35-4f75-98e3-9ad5c86a0111 splash=silent resume=/dev/disk/by-id/ata-Samsung_SSD_860_QVO_2TB_S4CYNF0M524385H-part3 mitigations=auto quiet

I must say it was a bit different from what I had expected.

That looks like the default boot command line, if it works for you don’t change it.
Maybe the installed kernel was updated relative to the installer’s one, so you don’t need the mce thing anymore.

Then I’ll leave it.

I appreciate your help, OrsoBruno - thanks a lot.