Trouble with Fallout 3

Fallout 3 seems to be one of the games that most people can get to run nearly perfect on Wine with some over rides. I on the other hand have been messing with it for weeks and CANNOT get it to work. I don’t understand it. I have followed the directions on the Wine site to the letter, I even tried what another guy that was having similar issues with openSUSE 11.3 did. All I get is a black screen and I usually have to ctrl alt backspace out of X to get out of it. When I run it in the terminal I get:

fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.VC90.CRT" (9.0.21022.8)
err:module:import_dll Loading library MSASN1.dll (which is needed by L"C:\windows\system32\xlive.dll") failed (error c0000024).
err:module:import_dll Library xlive.dll (which is needed by L"Z:\home\seth\.wine\drive_c\Program Files\Bethesda Softworks\Fallout 3\Fallout3.exe") not found
err:module:LdrInitializeThunk Main exe initialization for L"Z:\home\seth\.wine\drive_c\Program Files\Bethesda Softworks\Fallout 3\Fallout3.exe" failed, status c0000135

I have both the msasn1 and xlive dll files in the system32 directory, I even checked to make sure. And I have overriden anything that needed to be. I am running 11.2, I have all the updated drivers also.

This is really frustrating me as I would really like to play this game. I don’t understand why the programs can’t see the two dll files. It makes no sense unless they are looking in the wrong place.

Have you installed Microsoft Games for Windows - LIVE, MS Visual C++ 2008 libraries?
Take a look at How to get Fallout 3 Working with DLC

Yes, I have done everything over and over again. I have gone through about 6 new wine directories as I always start from fresh also.

The install directions for the game specifies using vcrun2005, but I tried to install vcrun2008 just to see if it helped, and it fails. Here is the terminal output:

drive_c already named harddiskvolume0
Using native,builtin override for following DLLs: msvcr90
Executing early_wine regedit c:\winetrickstmp\override-dll.reg

Executing wine /home/seth/.winetrickscache/vcrun2008-ms09-035/vcredist_x86.exe
fixme:clusapi:GetNodeClusterState ((null),0x32ec34) stub!
fixme:advapi:DecryptFileA “c:\0977cf605b5b2ec291e9\” 00000000
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
err:ntlm:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path.
err:ntlm:SECUR32_initNTLMSP Usually, you can find it in the winbind package of your distribution.
fixme:advapi:LsaOpenPolicy ((null),0x33f334,0x00000001,0x33f35c) stub
fixme:advapi:LsaClose (0xcafe) stub
fixme:advapi:LookupAccountNameW (null) L"seth" (nil) 0x7addcc (nil) 0x7addd0 0x7addc4 - stub
fixme:advapi:LookupAccountNameW (null) L"seth" 0x14fb90 0x7addcc 0x14f9a8 0x7addd0 0x7addc4 - stub
fixme:advapi:LookupAccountNameW (null) L"seth" (nil) 0x7add98 (nil) 0x7add9c 0x7add90 - stub
fixme:advapi:LookupAccountNameW (null) L"seth" 0x1623f0 0x7add98 0x168860 0x7add9c 0x7add90 - stub
fixme:msi:msi_unimplemented_action_stub MsiUnpublishAssemblies -> 10 ignored L"MsiAssembly" table values
err:msi:ITERATE_Actions Execution halted, action L"InstallFinalize" returned 1627

Note: command ‘wine /home/seth/.winetrickscache/vcrun2008-ms09-035/vcredist_x86.exe’ returned status 91. Aborting.

Hey Seth. I saw your comments on the Fallout 3 page. I’m one of the maintainers there. Later on tonight, I will do my best to help you out. How do you attempt the overrides in winecfg?

And another thing worth trying is to uninstall wine, dumping the .wine & .winetrickscache folders. I had to do this at one point on one of my OpenSuSE boxes to get it running appropriately.

Did you use a new Wineprefix also, or the default that comes with the fallout 3 launcher? (Or did you right click the file, open with wine / winebrowser?).

Edit: Oh! Completely forgot. There is an xlive.dll fix that I implemented on the Fallout 3 AppDB page. This is what I had to do to get around the issues I experienced with xlive.dll. Give that a shot. If this becomes an issue, we’ll attempt something else.