Trouble with Bridge Network Settings

Hi peeps,

I’m sweating it out trying to configure my home network; allow me to run through a quick description:

  • ADSL runs to a wired modem router (R0)
  • wireless router 1 (WR1) is plugged straight into a lan port of R0 and acts as the AP; on the lan side it has a fixed IP ( and also acts as DHCP server, in case a laptop gets plugged in directly.
  • wireless router 2 (WR2) sits one floor up and is set up as a wireless bridge connecting to WR1’s wireless network(both routers are linksys units running DD-WRT firwmare). WR2 has DHCP disabled and has a lan IP of
  • In the LAN ports of WR2 are the interesting bits: one SuSE machine, one windows machine and a little NAS box.

The headache is this: I can’t seem to find the right settings for SuSE to connect to the network. My adaptors are recognised; but I tried every way possible, Yast Network Settings always fails at the last stage (resolving download.suse.watsit). I tried dynamic IPs, Fixed IPs, setting the gateway to either or; nothing for it. If anyone had any recommendations as to how to set this one up I would be most grateful. I suspect it might be the name server thing getting in the way, seeing as the windows setup didn’t ask for this, only the gateway, I don’t know exactly what to do with that one. For the moment I’m only trying to get the browser and updater working. And the windows connection actually works with DHCP funnily enough, it looks like the request travels straight through WR2 and into WR1 and gets back successfully.

So from your description, R0 and WR2 are separate physical subnets but yet have the same subnet address That doesn’t sound like it would work, unless by the ambiguous phrase “LAN side on WR1” you actually mean the inside address of WR1, not the address of the ADSL router facing side.

Since WR2 is effectively just an extension of WR1, it should work and it does seem to work for Windows. The DHCP reply should come from WR1. This should be the default setup for SuSE acquiring an address by DHCP.

Check these pieces of info:

/etc/resolv.conf should have WR1 as the DNS resolver
/sbin/ipconfig should show an address in the subnet
/sbin/route -n should show that the gateway is WR1
dig @WR1 should get a reply from WR1

Hi Ken,

actually the full setup is this:

  • R0 WAN: dynamic, from ISP
  • R0 LAN: 172.xx.xx.xx
  • WR1 WAN: 172.yy.yy.yy
  • WR1 LAN:
  • WR2 (Bridge) LAN:

…with the DHCP of WR1 handing out 192.168.1.(5/6/7/8)

I think it should hold up; I’ll check out your references, thanks for those.

Quick update and thumbs up for the record, it works now. I put it back to DHCP seeing as all other devices on the network were doing ok with dynamic IPs, and I activated the major options for DHCP (change default route via DHCP, get DNS from DHCP). The only weird thing is that when I exit NetworkManager it fails to resolve the and I have to hit ‘retry’, at which point it works. Small price to pay though.

In fact I’m typing this into Firefox straight from SuSE :stuck_out_tongue:

If it’s a non-roaming machine you could active the network at boot with ifup and DHCP, instead of using NetworkManager, which requires login.

To be honest I actually tried setting the adaptor to ‘activate on hotplug’ because it made the most sense to me, activate whenever a cable is in; but I found the sneaky ****** back in ‘activate at boot’ :open_mouth: I did try to go through ifup during my tests, but not since I got it all working so I never saw ifup running. This is my first linux install (64bit on an intel quad core with 2 GB of DDR3 until the price of those goes down a bit and I can go nuts without the guilt) and I’m discovering as I go along. I don’t know what the fundamental meaning of anything is. I apply my general knowledge (for example basic DHCP usage) but I couldn’t say which of ifup or NetworkManager is edible and which smells of socks. Reading between the lines I’m thinking that NetworkManager requires root password to activate the network? I’ll look into it though so thanks a lot for the tip.