Trouble with automounting...

hi everyone!

I’ve reacently installed OpenSuSE 11.1 Gnome on my EeePC.
I runs great althought a few days ago it just stoped automounting pen drives and memory cards…
I’ve google quite a bit but found nothing that could fix my problem.

I found threads saying i should change something in /usr/share/Policykit/policy…
another one sayd i should do a command like polkit-auth --grant…]
and a few more which i tried and did not help

I’ve tried reinstalling the Hal package…

Nothing seems to work :frowning:

Does anyone have any ideias??

could be this

https://bugzilla.novell.com/attachment.cgi?id=262331&action=diff

thank you very much for the hasty reply.
however I’ve allready tryed doing that and it didn’t work…
I’ll try it again anyway

Could it be in any way related to beagle? I removed most of it’s packages…

Could it be in any way related to beagle? I removed most of it’s packages…

No.
Beagle is nothing to do with this.
I’m really not sure why you are getting this happen. Some kde users have had difficulty with the new Dolphin file manager but even that is not an issue really.
Are you upto date?

zypper ref
zypper up

The system was up-to-date.

I used to have KDE 4.1.3 before gnome and didn’t have any trouble like this. I only changed to gnome because KDE took to long to login.

I’ve notice something else when i plugin a usb pen drive. An icon on the notification area. It quickly goes away but if a click it fast enough a small menu show up with two buttons. One says “Refresh software list” and the other says “Getting what provides /org/freedesktop/hal/devices/usbdevice/54c2432A080305B7496”
If i click those nothing really happens.

I saw on a forum somewhere that i should have a process like resmgr or something and that i should change something in /etc/resmgr.cong but neither of those exist.

Is there any output that could help find out what the problem is?

Hi

Had the same problem too.

Solution (for me, SuSE 11.1 x86_32):
Go to /usr/share/PolicyKit/policy/
edit file org.freedesktop.hal.storage.policy

change line 32 of this file below action:
<action id=“org.freedesktop.hal.storage.mount-removable”>
to read:
<allow_inactive>yes</allow_inactive>

This was set to “no” before.

Then as user root:
rchal restart

Now my memory stick automounts ok.

Regards, Thomas

worked for me too! thanks for your reply :slight_smile: