Trouble upgrading to 42.3

I have tried to update my laptop to 42.3 but it is giving error messages.

Laptop is running 42.2 on btrfs files. When I follow the instructions on SDB: System upgrade all is ok until section 3 after I have mounted subvolid=5 and I try to mv /mnt/var/cache when it says the device is busy so no cache.old is created.

I do not know what to do now. Btrfs is outside my knowledge but was installed when laptop was new.

What should I do now?

I followed the advice on this page and all went well, Seems that you need to be sure to disable any third party repositories you may have added.
You can re add them later.

Yes but … I have not got that far! The instructions at SDB:System_upgrade give a blow by blow recipe and they fail in part 3 before disabling third party repos. As I said I an running btrfs which as an extra step involving mounting a subvolume, which I did. The next stage is to move /mnt/var/cache to mnt/var/cache.old
When I try that it says device is busy, so I stopped not understanding what all the btrfs stuff is about

I may add that the first 42.2->42.3 (Lenovo laptop with ext4) was OK apart from the two small issues I raised in another thread, and the third attempt (desktop with ext4) worked perfectly. So I am reasonably happy with ext4 systems (one more to upgrade), but am lost wrt btrfs

OK about this problematic “Step 3” of the SDB: System Upgrade
Admittedly, like the referenced “openSUSE Leap 42.3: Get ready to upgrade” I didn’t execute these steps “preserving volatile data.”
So, let’s take a look at what is in there, the following list is incomplete

  • process data for the current running session
  • old zypper package installs (presumably to uninstall old versions?)
  • Various configurations
  • snapshots

Basically, it looks like snapshots for the current running system plus possibly some custom configuration data.
I personally don’t modify my GUI at all and use default settings, and once upgraded I don’t expect to want to ever downgrade to the previous openSUSE, so I don’t mind “losing” all that. Whatever is default will likely be over-written by the upgrade to new defaults.

But, if you do want to preserve all that through the upgrade, then you’ll need to execute the steps described in

And, although the steps are described it can all look very confusing because of all the optional steps and lack of detailed explanation what each step is accomplishing. Personally, if I wrote the SDB, I would have modified the info to display in a hierarchical fashion reflecting the options versus the required steps, and possibly incorporate all the commands in this step into a verbosely commented script (although I don’t know if I would spend the time to fully automate it).

**For the specific step where you’re experiencing problems **

mv /mnt/var/cache /mnt/var/cache.old

Before executing that step, I’d recommend first inspecting that location to see if there is anything of value. If the file location is empty, skip moving the empty folder. Something like the following command will test whether there is anything

ls /mnt/var/cache

If you really do have something in that location, you can try moving the individual contents instead of the folder with its contents with something like

mkdir /mnt/var/cache.old
mv /mnt/var/cache/* /mnt/var/cache.old/

and if the above <still> won’t run because a file is locked, then you can “cp” the file instead assuming that after the upgrade the process will be terminated.

In any case, you should consider whether you’ve stopped all unnecessary applications before upgrading, the running process <might> cause an upgrade problem.


Oh dear! it looks as if my attempt to reply failed.

I tried what you suggested but it the same problems so I just went ahead with not fiddling with the btrfs stuff. It seemed to work and I have been running 42.3 apparently without problem for weeks. No idea if I lost some file space, but I did notice my disk usage is 10% higher than it was.

Thank you for your help.