Trouble setting up SABnzbd

I searched for SABnzbd in and used the 1-click install to set it up. From looking over an older tutorial, I’m apparently supposed to run a python script called that is located in the install directory. When I try to run it, I get this error message:

Traceback (most recent call last):
File “/usr/share/SABnzbd/”, line 66, in <module>
import sabnzbd
File “/usr/share/SABnzbd/sabnzbd/”, line 72, in <module>
from sabnzbd.nzbqueue import NzbQueue
File “/usr/share/SABnzbd/sabnzbd/”, line 28, in <module>
from sabnzbd.nzbstuff import NzbObject
File “/usr/share/SABnzbd/sabnzbd/”, line 40, in <module>
from sabnzbd.misc import to_units, cat_to_opts, cat_convert, sanitize_foldername,
File “/usr/share/SABnzbd/sabnzbd/”, line 45, in <module>
import sabnzbd.growler as growler
File “/usr/share/SABnzbd/sabnzbd/”, line 33, in <module>
from gntp import GNTPRegister

Any ideas?

Oops! Forgot the last part of the log…

ImportError: cannot import name GNTPRegister

From which repo did you install SABNzb? Which version?

Please post output from

zypper se -i -s sabnzb

, between CODE tags.

Plus, how do you run SABnzb? I do, as user, not as root:

cd /usr/share/SABnzbd

I pulled it up here and installed SABnzbd from the bmanojlovic repository:

S | Name    | Type    | Version     | Arch   | Repository      
i | SABnzbd | package | 0.7.11-15.2 | noarch | home:bmanojlovic

It doesn’t seem to make a difference which user I run as, my regular user or root; I get the same message.

Interestingly enough, I tried downloading the source from SABnzbd’s Web site and it runs perfectly well. Is there a problem with the way this particular repository has packaged it?