Trouble Installing openSUSE on T470 that had Windows 10 Pro - NON-DUAL-BOOT

I’ve run into a glitch installing openSUSE Tumbleweed on my new Lenovo T470 with SSD. I was able to boot from USB and install the Linux OS, but on restart I’m getting the Windows recovery blue screen with error 0xc0000225 asking me to recover from my Windows 10 recovery USB (which I have).

I am currently able to boot to the openSUSE install USB, then boot from disk, but I need to just boot to openSUSE.

I have no use for windows 10 on this system, and I am happily running openSUSE Tumbleweed on my older T400. I am not interested in dual boot, since I have no need for windows 10.

I there a some thing I need to do or remove from the disk partition to allow boot to progress to grub?

I don’t mind a solution that requires me to install Tumbleweed again.


I don’t have a T470.

On my Lenovo ThinkServer, I have to go into BIOS settings to set opensuse to be first in boot-order. Actually, it is “opensuse-secureboot” that I have to make first.

The Lenovo firmware (BIOS) likes to control the boot order. I’m guessing it is the same for your system.

There was a trick by replacing the Windows efi boot files with matching renamed files from openSUSE efi boot files then the UEFI is tricked into booting openSUSE. Don’t know if it still works.

Since the OP has no need for Windows 10, he can delete the Microsoft directory in the EFI partition (’/EFI/Microsoft’ relative to that partition). That might be enough to convince the firmware to not try Windows. Perhaps also delete ‘/EFI/Boot/bootx64.efi’ (which is likely also a Windows file).

Since my T400 disk is the same size as my T470 I’m thinking of restoring one of my T400 Clonezilla snapshots to the T470 then reinstall openSUSE with my preferred partitioning.