trouble installing HP officejet 5610 printer/scanner/fax

I’ve downloaded hplip-2.8.12 and followed the installation instructions at HP Linux Imaging and Printing . Each time ‘make’ comes up with error status code 2. I’m running opensuse 11.0. Where can i get a list of error codes? How can i get my printer working? Pls help the newbie.

To compile (that is what the make command is doing) you need to have things like gcc installed.

Compiling software - openSUSE is a really good starting point to learn how to get things compiled.

I would stick with the first part, dealing with installing the right stuff to get it to work. The C/C++ parts are mandatory. There will be other dependencies that YaST will automatically pick-up. Also make sure that gcc is there as well

Also any errors that come up can be used to search google or here. you will find some information and a fix for errors. Not just for this, but anytime things don’t work.

Thanks, but still no luck. gcc and dependancies all seem to be there. ‘make’ still giving an error status code 2.

It asked that i disable al CD repositories in yast. Does that just mean unchecking the “enabled” column of items with a URL of cd:… ?

Yes. To disable a repository just un-check enable.

A couple of more things to check in YaST:
autoconf, automake, kernel-source and qmake

Thanks Cybertaz
I’ve installed everything you mentioned through software update in yast, but no luck.
Strangely tho, i tried the printer option in yast today (which is how i originally tried to install the printer) and it now works! Don’t know what changed.

Can’t get it to scan tho. HP normally have an interface page allowing you to manage the printer/scanner/fax/copier options. Does this run in linux distros? Ideas?

the hplip software installs an icon in the system tray that has that screen.

Just a thought, did you do automatic or custom install? I did custom and had no problems.

Tried a single click install. Said it was completed ok, but no change.

Added autoconf, automake and qmake and re-tried through konsole. Same error during ‘make’.

Added kernel-source and all seemed well. But no hp button on the panel. But could now use the scanner option through Xsane.

Wanted to try through ‘add new printer’ again but found there were now two hp5610’s installed. Deleted one.

Inexplicably i now see the hp button on the panel. And everything works. No idea why this didn’t happen on any previous restart, although i didn’t think it would be necessary.

Happy. And very appreciative of your time. I’m very keen on getting into linux, i believe open source is the only ethical way forward. How did you learn more? Any sugestions?

Thank you so much.

google is often your friend too;

if you google on

error status code 2 linux

you get such things as

[Hplip-help] error messages: ¨’make’ comma nd failed with status code 2¨](


Re: [Hplip-help] error: ‘make’ command failed with status code 2

and how to exit from error codes

How to Get Exit Status Codes from Linux Command Prompt | Code Retard

delighted to hear you got this fixed; we hope it remains as a permanent solution; the error 2 returns common opensuse answers;

seems like there can be many missing packages that give an error 2 message, with hplip;

all best wishes