trouble installing flash 10

i have been having a problem with flash crashing and it causes firefox to crash

this has been a very well know problem with flash and firefox for a long time now

but now flash 10 is availible and they supposedly have fixed the linux crashing problems

so i wanted to install flash 10

first i removed flash-player (9) with yast

then i downloaded the .rpm from adobe’s website

i installed the .rpm and rebooted, then i opened firefox but it does not recognize the plugin

it says i dont have flash installed

so i uninstalled the .rpm with yast and i downloaded the .tar.gz

i did ./flashplayer-installer as root and followed the steps

it asks me where the installation directory is

so i choose /home/tj/.mozilla

it gives an error and says please use a valid installation directory

(i just gave up and reinstalled flash 9)

so now im completey at a loss

how can i install flash 10 in openSUSE 11?

nevermind

sorry guys i solved my own problem

it turns out that when you are installing the .tar.gz version you shout not use root

it worked first try after running ./flashplayer-installer as a user