Trouble in Installing Request racker 3.6

Hi I am new to linux and learning it. Currently I have task to install the RT-3.6 in my openSuse 10.3. I tried installing the dependent perl modules and got stuck . here are the details.

OS – OpenSuse 10.3 .
RT – Version is 3.6.6

STEP:1 → I xtracted the software in /tmp folder and ran the command ./configure. and it went smoothly.

STEP:2 → Then I ran the “make testdeps” as in the installation guide and it showed both missing and found dependencies.

Bandtel2:/tmp/rt-3.6.6 # make testdeps
/usr/bin/perl ./sbin/rt-test-dependencies --verbose --with-mysql
perl:
>=5.8.3(5.00800…found
users:
rt group (www)…found
bin owner (root)…found
libs owner (root)…found
libs group (bin)…found
web owner (nobody)…found
web group (www)…found
CLI dependencies:
Term::ReadKey…found
Getopt::Long >=2.24…found
HTTP::Request::Common…found
Term::ReadLine…found
Text::ParseWords…found
LWP…found
CORE dependencies:
Scalar::Util…found
HTML::Scrubber >=0.08…found
Class::ReturnValue >=0.40…found
Text::Quoted 2.02…MISSING
File::Spec >=0.8…found
Calendar::Simple …MISSING
DBIx::SearchBuilder 1.50…MISSING


rest are omitted for brevity

while I am trying to install the Text::Quoted I found that it depend on Text::Autoformat which in turn depend on Text::Reform .

I installed Text::reform without any problem. When I tried to install the Text::Autoformat it gave an error that "break_at " was not exported by Text::reform . I tried to fix it after googling how to fix it but unable to do so.


Below are the CLI details:

But when I tried again to install the Text-Autoformat I got an error message which is pasted here for you view.

noc2@Bandtel2:~/Desktop/Text-Autoformat-1.12> make test
PERL_DL_NONLAZY=1 /usr/bin/perl “-Iblib/lib” “-Iblib/arch” test.pl
1…1
“break_at” is not exported by the Text::Reform module
Can’t continue after import errors at /usr/lib/perl5/site_perl/5.8.8/Text/Reform.pm line 43
BEGIN failed–compilation aborted at blib/lib/Text/Autoformat.pm line 9.
Compilation failed in require at test.pl line 13.
BEGIN failed–compilation aborted at test.pl line 13.
not ok 1
make: *** [test_dynamic] Error 255

→ I tried googling and tried to relplace the Reform.pm of Text-Reform 1.10 with the same version from CPAN and again with that of the Text-Reform-1.11 but failed on both occassion.


FYI I have pasted the README file of the RT package below

RT is an enterprise-grade issue tracking system. It allows organizations
to keep track of what needs to get done, who is working on which tasks,
what’s already been done, and when tasks were (or weren’t) completed.

RT doesn’t cost anything to use, no matter how much you use it; it
is freely available under the terms of Version 2 of the GNU General
Public License.

RT is commercially-supported software. To purchase support, training,
custom development, or professional services, please get in touch with
us at sales@bestpractical.com.

Jesse Vincent
Best Practical Solutions, LLC
March, 2005

REQUIRED PACKAGES:

o Perl 5.8.3 or later (Perl.com: The Source for Perl – perl development, conferences).

Perl versions prior to 5.8.3 contain bugs that could result
in data corruption. We recommend strongly that you use 5.8.3
or newer.

o A supported SQL database

Currently supported: Mysql 4.0.13 or later with InnoDB support.
Postgres 7.2 or later.
Oracle 9iR2 or later.
SQLite 3.0. (Not recommended for production)

o Apache version 1.3.x or 2.x (Welcome! - The Apache HTTP Server Project)
with mod_perl – (mod_perl: Welcome to the mod_perl world )
or a webserver with FastCGI support (FastCGI Home)

Compiling mod_perl on Apache 1.3.x as a DSO has been known
to have massive stability problems and is not recommended.

mod_perl 1.x must be built with EVERYTHING=1

RT’s FastCGI handler needs to access RT’s configuration file.

o Various and sundry perl modules
A tool included with RT takes care of the installation of
most of these automatically during the install process.

The tool supplied with RT uses Perl’s CPAN system
(CPAN) to install modules. Some operating
systems package all or some of the modules required, and
you may be better off installing the modules that way.

GENERAL INSTALLATION

This is a rough guide to installing RT. For more detail, you’ll
want to read a more comprehensive installation guide at:

InstallationGuides - RT Wiki

1 Unpack this distribution other than where you want to install RT

To do this cleanly, run the following command:

tar xzvf rt.tar.gz -C /tmp

2 Run the “configure” script.

./configure --help to see the list of options
./configure (with the flags you want)

RT defaults to installing in /opt/rt3 with MySQL as its database. It
tries to guess which of www-data, www, apache or nobody your webserver
will run as, but you can override that behavior.

3 Make sure that RT has everything it needs to run.

Check for missing dependencies by running:

make testdeps

4 If the script reports any missing dependencies, install them by hand
or run the following command as a user who has permission to install perl
modules on your system:

make fixdeps

5 Check to make sure everything was installed properly.

make testdeps

It might sometimes be necessary to run “make fixdeps” several times
to install all necessary perl modules.

6 If this is a new installation:

As a user with permission to install RT in your chosen directory, type:

make install

Set up etc/RT_SiteConfig.pm in your RT installation directory.
You’ll need to add any values you need to change from the defaults
in etc/RT_Config.pm

As a user with permission to read RT’s configuration file, type:

make initialize-database

If the make fails, type:

make dropdb

and start over from step 6

REST OF THE FILE ARE OMMITED FOR BREVITY


Is there any RPM package available for RT-3.6. or do we have to install it manually.

I am blind from here and any help to proceed further would be appreciated

Thanks and Regards
mysuselove
:slight_smile:
mysuselove is online now Report Post Reply With Quote

Hi
Why not just run cpan from the cli and install them that way, then you
shouldn’t get any dependency problems.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 0:03, 1 user, load average: 1.05, 1.12, 0.50
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12