Trouble getting earbuds to show in Audio settings

I have a pair of Axiom M2 computer speakers hooked via USB cable to my openSuse Tumbleweed desktop computer, with KDE. [5 years] The speakers have their own DAC and are not run thru the computer onboard sound. The onboard sound is turned off via uefi bios. If needed, motherboard is Asus Z390-A.

I am trying to get a pair of bluetooth earbuds to work with the Axiom M2 speakers.
The earbuds do connect via bluetooth to the computer thru a program called bluetoothctl [in terminal].
They are paired and connected according to bluetoothctl, but when I play an mp3 the sound does not come through the earbuds

The sound software I am using is Pulse audio. The speakers work well.

When I open System settings> audio the Axiom M2 speakers show, but the earbuds do not.
I am unsure what next steps would be to make these earbuds work. My speakers are not bluetooth capable, but shouldn’t I be able to somehow get the earbuds to work? Maybe I need to turn my onboard sound back on? I am also inquiring about this at the speaker company forums.
Please advise?

With your BT earbuds confirmed as paired, check what is reported by the following commands

wpctl status
pactl list sinks

Most TW users are using PipeWire these days…I assume that you’ve made a deliberate choice to stay with using PulseAudio exclusively? PipeWire can be used with the ‘pipewire-pulseaudio’ package (pipewire-pulse daemon) to provide PA compatibility if needed.

This thread may also be of value to you…

Another suggestion to move to using pipewire and ‘pipewire-pulseaudio’…


Recently, I have seen mention of pipewire in several posts but have not checked into it yet, doing so now.
Would I just uninstall Pulse audio and install pipewire?

I have not made a “choice” to stick with pulse.
When I first rec’d the Axiom speakers, their tech had me insert 3 files regarding sound and setup for the speakers.
I can share them here if you need to see them.
I am wondering would I have to get different files if I changed to pipewire?
Is this something I would need to check with the manufacturer?

I will do those commands you suggested soon. I do not have access to the PC today.

As a TW user I would have expected that pipewire is already installed. It is likely that both are installed. You can check the installed packages with

zypper se -si pipewire pulseaudio

If you install the ‘pipewire-pulseaudio’ it will remove pulseaudio (as the two would conflict), and you can check the behaviour at next boot.

I’m curious as to what those files are. However, let’s see if pipewire is already installed (as I suspect it will be), and you can replace ‘pulseaudio’ with ‘pipewire-pulseaudio’ simply by installing the latter.

If pipewire is not already installed I will do it when I get home tonight.

I now have pipewire installed using zypper:
sudo zypper in gstreamer-plugin-pipewire pipewire-alsa pipewire-aptx pipewire-libjack-0_3 pipewire-pulseaudio libfdk-aac2 libopenaptx0

and I rebooted the PC.

Sound works OK, but now onto getting earbuds working. I will try to pair and connect buds tonight.


I have finally got these earbuds working after I installed pipewire.
They connect on their own and show up in System Settings>Audio where I can toggle between speakers and ear buds.
A couple of things I need some advice on:
1] I am experiencing intermittent sound cutting out/in while playing music.
Is there a way to adjust so that this does not happen?
2] Is there a way to have a short cut on the Task Bar that I can click on to toggle between speakers and earbuds?
Or another way to do this toggling?

See if this helps for intermittent audio…
Audio cutting out when multiple streams start playing
Specifically, the section relating to wirelplumber.

Not sure which kernel version you have, but I’ve read about some kernel-related issue fixed with kernel 6.1. Just in case this is impacting…

I’m not sure what is possible with respect to a toggling shortcut on the task bar. Switching audio output could be done via a script reasonably easily, and executed via a widget I guess. Hopefully someone else can advise here.

thank you @deano_ferrari

I have kernel 6.1.12-1 default 64 bit.
Reading on your suggestion links now.


From the pipewire wiki section 5.1.14 Audio cutting out when multiple streams start playing- With [wireplumber]

With wireplumber:

/etc/wireplumber/main.lua.d/50-alsa-config.lua (or ~/.config/wireplumber/main.lua.d/50-alsa-config.lua)

apply_properties = { [“api.alsa.headroom”] = 1024, },

I do not find this file in the same path as mentioned above. Does this matter?
My path is:

and in that file:
apply_properties = { [“api.alsa.headroom”] = 0, },
where api.alsa.headroom is 0 NOT 1024, so I should change this to 1024?

I would create ~/.config/wireplumber/main.lua.d/50-alsa-config.lua and add the entry. Then restart the service with

sudo systemctl --user restart wireplumber

See how that goes.

FWIW, more information about the ALSA buffer explained here…


I would create ~/.config/wireplumber/main.lua.d/50-alsa-config.lua and add the entry. Then restart the service with

sudo systemctl --user restart wireplumber
I created this file 50-alsa-config.lua in this path:
*NOTE: As they did not exist I created wireplumber and main.lua.d 
file folders*

I copied the contents of the 50-alsa-config.lua from the file found Here:
and I changed the line at 143 to "apply_properties = 
{ [“api.alsa.headroom”] = 1024, },"

**Was this specifically how you meant me to do this?**

I then ran "sudo systemctl --user restart wireplumber" in terminal.
this was returned:
dabud@localhost:~> sudo systemctl --user restart wireplumber
[sudo] password for root: 
**Failed to connect to bus: No medium found**

NOTE:Before I performed the above work I tried a different set of 
bluetooth headphones and the crackling/breakup of audio still occurred. 
Neither of these bluetooth sets has any breakup or crackling on other devices. 
[i.e.- samsung tablet or phones]

Once again thank you for your suggestions and help.

Sorry that should have been as user…

systemctl --user restart wireplumber