Trouble connecting to remote desktop

I need to connect to the desktop of my XP PC at my home but am having trouble.
I’m trying the command

rdesktop -z -a 16 -g 1024x768

as detailed in Swerdna’s post.
I’m using Dyndns to track my changing IP address.

This worked fine from within the LAN (addressing the PC using the dyndns domain) but for some reason now when I’m in another location and try the command above nothing happens.

I can however connect using KRDC but the connection is not encrypted so I don’t want to use that. At least it proves the connection is possible and the necessary ports etc are open.

I’ve tried turning my openSUSE firewall off but it didn’t make a difference.

Any ideas?

How does your PC at home connect to the Internet? Does it connect thru a router?

If so, have you tried to setup your router to tell it to pass the external connection on to your PC ? Note since the external connection is initiating the communication, this is necessary. Routers are typically built to handle more than one pc, and hence if you do not do this, how will the router know what PC to send the connection attempt to?

Yes the router is set to forward port 3389 to the IP of the PC I’m trying to connect to.

I know it works because I am able to connect using KRDC (KDE’s remote desktop client). The reason I am not comfortable using KRDC is because it doesn’t encrypt the connection between the two computers.

Just can’t figure out why rdesktop isn’t working though.

I don’t use rdesktop myself (I use vnc) so I’ll have to let someone with rdesktop experience step in … but one non-rdesktop user’s question … On my router at home, when I specify port forwarding, I need to specifiy whether I am forwarding tcp or udp or both. My (albeit limited) understanding is for rdesktop this is udp you need to forward. Did you make certain it was udp and not tcp?

And other than that, its over to the rdesktop experts to help.

Edit - although having typed that about UDP, I find this table confusing: List of TCP and UDP port numbers - Wikipedia

RDP/XRDP uses tcp 3389

Yep TCP is set on port 3389 forwarding. Tried UDP just because I ran out of ideas but it didn’t help.

Note, the firewall of the site where you are located at now could also be blocking this traffic.

Where I work, the corporate/government firewalls block all vnc/rdesktop traffic.

Try going to an Internet cafe with a laptop, or to a friend’s house, and see if that makes a difference.

I don’t think it’s firewalls as I’m trying from residential locations. Have tried in 2 different friend’s locations and no go.

I just tried to connect with KRDC and that won’t connect any more. Worked fine yesterday. Maybe my PC at home has developed a problem - after all it’s running windows and hasn’t been rebooted for over a week :stuck_out_tongue: