Trouble Adding a New Hard Drive

First off, I want to apologize, as I am a complete Linux noob, so this may be just a “duh” problem.

I’m trying to add a second hard drive to my Linux box, but I can’t seem to get the file system working on it. Specifically, it’s as if Linux doesn’t even see the drive there.

So my first question is this: I’ve plugged in the hard drive - now what? What should the steps be?

Second, what’s going wrong? Some clarification: When I boot, the BIOS recognizes the hard drive, but when I go to Hardware Configuration in YaST, it only lists my primary drive.

Any pointers would be greatly appreciated!

There are a couple places you can look, to see if the hard drive is recognized. First, your hard drives should all be listed in the /dev/ directory in your filesystem as “sda”, “sdb”, “sdc”, etc. The partitions on the drives will be listed as sda1, sda2, etc. You can look to see what drives you have listed there.

Also, you can go into YaST>>System>>Partitioner. Before you can use the drive, you will have to set up one or more partitions, and mount them. In the partitioner, you will see all the hard disks listed under the “Hard Disks” on the left-hand side (listed as /dev/sda, /dev/sdb, etc). Under each drive, the partitions will be listed.

If you don’t have any partitions on the drive, you won’t be able to use it for storing files. You can create partitions here, but be sure to do it on the new drive, not the old. Deleting or changing existing partitions can result in data loss.

Okay, I’m glad to hear I wasn’t too far off in my thinking, as I checked both places. I tried the Partitioner first, but when the hard drive wasn’t listed with my primary, I checked /dev/. Unfortunately, only sda and the sda#'s were listed (presumably, the new drive should show up as sdb, correct?), so I thought maybe I was missing a step in there somewhere.

Any reasons why it’s not showing up in either place?

I will admit we are quickly approaching the end of my knowledge. There are a few things I would look for in troubleshooting. First, does your motherboard have a RAID or built-in backup solution, either in the bios or hardware, that might be selected and using the drive? I know mine does, as well as several others. If it is something bios-controlled, look there for the options. If it is something hardware controlled, try swapping which sata port you are connecting to on your board.

I don’t have a lot of other ideas at this point. Good luck.

> Any reasons why it’s not showing up in either place?

if the new drive is an IDE (not a SATA) drive it will show up as hda,
not sda…i think…

Andy Sipowicz

In response to Andy: No, my primary hard drive is IDE, and it shows up as /dev/sda (presumably “Storage Device A”).

In other news:
On a hunch, I tried playing with jumper settings on the drives (making sure they were cable select), and tried adding in a smaller-size drive I had on hand in case the problem was size-related. Lo and behold, Linux recognized the smaller 40GB drive no problem!

Now, of the 5 160GB drives I have (all IDE), one of which is my primary, three of them are the same model, so I tried the last one I had. Linux recognized that one also. Apparently, the problem is limited to the three Maxtor drives (model 4G160H8, to be specific). Has anything like this occurred before? Keep in mind also that all of these drives worked fine when I had Windows XP …