triple booting problem

hey guys,

jus tried triple booting xp, ubuntu and opensuse. result: failure!
i had xp and ubuntu 9.10 dual booting previously, added opensuse 11.2 just now and the grub seems to have disappeared, wen i start my machine now i just get three options - opensuse 11.2, windows, failsafe opensuse

what do i do???

this is my output of fdisk -l if u need it. please help !!!

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xe603e603

Device Boot Start End Blocks Id System
/dev/sda1 1 5357 43030071 7 HPFS/NTFS
/dev/sda2 * 5358 18643 106719795 f W95 Ext’d (LBA)
/dev/sda5 5358 12998 61376301 7 HPFS/NTFS
/dev/sda6 16155 18519 18996831 83 Linux
/dev/sda7 18520 18643 995998+ 82 Linux swap / Solaris
/dev/sda8 12999 16154 25350538+ 83 Linux

I think Grub2 (Ubuntu’s grub) got removed when you installed OpenSUSE. By default this installs a Grub version of it’s own.

Can you post the content of /boot/grub/menu.lst?

Also have a look at this page: Configuring Grub with YAST
The rest of the page might also be of some help.

I am uncertain wether the ubuntu version of GRUB2 can be recovered. Maybe someone else can help with this. I personally find OpenSUSE’s grub better looking lol!

menu.lst was empty but here is my menu.lst.old

Modified by YaST2. Last modification on Thu Feb 11 22:45:13 IST 2010


Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,7)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.2
root (hd0,7)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-ST3160215AS_5RA2WAB4-part8 resume=/dev/disk/by-id/ata-ST3160215AS_5RA2WAB4-part7 splash=silent quiet showopts vga=0x31a
initrd /boot/initrd

###Don’t change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,0)
chainloader +1

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.2
root (hd0,7)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-ST3160215AS_5RA2WAB4-part8 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31a
initrd /boot/initrd

nitstorm wrote:
> what do i do???

here is one way:
“How to install and boot 145 operating systems in a PC”


#Don't change this comment - YaST2 identifier: Original name: none#
title Ubuntu booting via symlinks
root (hd0,9)
kernel /vmlinuz root=/dev/sda8 ro quiet splash
initrd /initrd.img

add that onto the end of your /boot/grub/menu.lst. I beleive that is the code if not let me know. If that is not the code it will not mess up booting xp and suse.

I’ve found that the best way to manage your situation is by following these steps.

After booting into Ubuntu run

sudo update-grub

Your problem should be solved after this.

just double-checked that, it should be a good code. Go ahead and try it.