Triple Boot - Leap 15.1, WInows 10, Windows 7 - time synchronization problem

Leap boots up withe the proper time and date. Win 10 boots with proper time and date. Windows 7 boots woth proper date, but is behind by 6 or 7 hours(I forget which).
I have added the ‘RealTimeIsUniversal’ registry entry and it is set to 1. It is a 64bit DWORD.

I ‘triple boot’ Leap15.1, Win 10 and Win 7. I need Win 7 for some things that are very hard to do in Win 10 because of the MS take over OS attitude and rob resources.
Boot sequence via Grub2:
1- Leap 15.1
2- Leap 15.1 Advanced
3- Windows 10
If I choose 3, I get a Windows boot menu:
1- Windows 10
2- Windows 7
3 Leap(because I have not had the nerve to get rid of easyBCD).

My problem is Leap, and Win 10 both start with correct times.
Win 7 does not(it is behind about 6 or 7 hours, I forget which, I am in U.S. Central time zone)
IIRC, I set the Leap clock using the ‘hwclock’ command line.

Any suggestions?
If I add Win 7 to the Grub2 menu, will that help?

Go into the BIOS and check the time is set to UTC, then in Win7, just make sure the timezone is set to Central time…

A likely big hint of your misconfiguration is your error…
Note that USA Central Time zone is offset 6 hrs, and Daylight Savings Time likely accounts for that extra hour.


That should make it 5 hours, not 7 hours.

Note that I am in the Central Time zone, and I have never seen 7 hours off.

I don’t have Windows 10 (I am avoiding it). Windows 7 seems to work fine with the registry setting to use UTC – except that Window 7 at one time would set the time wrongly (1 hour off) when setting time from the Internet. I’m not sure if that has been fixed. My easy workaround for that was to tell Windows to never set time from the Internet. I allowed openSUSE to manage that synchronization.

You both are right, it wasn’t 6-7 hours it was 5 between going from Leap to Win 7.

**But it gets weirder still. **
Leap is a constant as far as the time goes and always correct.
If I close Leap and open Windows 10, then Win 10 has correct time(assuming it was correct at last shutdown/restart).
If I close Leap and open Win 7, then its clock is ‘advanced’ the 5 hours. I haven’t been able to solve that! SO I set the correct time, and reboot into Win 7 and it still is correct time.
This is the really odd thing, If I close out Win 7 and boot into Win 10, it’s clock is BEHIND the 5 or 6 hours.
Both Windows are set the same. UTC-0600

I can’t find search information that say the ‘triple boot’ is the problem.
That is why I was wondering if adding Windows 7 manually to the Grub2 menu might help this? Also taking out easyBCD from the Windows boot menu.

I looked at every option I could find in the BIOS menu(s).
The BIOS in this old HP desktop doesn’t have a specific UTC setting that I can find.
The BIOS time and date are the only changeable options.
Time in 24 hours format and can’t be altered to 12 hour format (is that UTC?)
Date in month/day/year format.

Yes, that’s the place to set UTC time…

To check from linux run;

date&date -u

Fri 04 Oct 2019 01:56:21 AM UTC
Thu 03 Oct 2019 08:56:21 PM CDT

I am trying to get back to Win 7, and rid of Win 10, but it is taking a lot of back and forth to get my things to Win 7.
MY OPINION! Avoid Windows 10 at all costs! It is getting more sickening every day, and I am truly sorry I ever put it on this old HP desktop,
But I need the both for now until I can find time to devote to removing Win 10 and hoping the Leap OS Prober will pick up on the change.
Then again, I may be blooding my head by slam it into brick walls, and getting hings more balled up than they are at present.

It’s pretty easy to turn all the carp off… kill of cortana with a few commands, delete all the extra stuff and should be good to go?

What do you need to run in Windows, remember only a few more months for Win7…

I think my Windows both still have one of the Internet settings enable. Will have to double check.

Mind my asking how you do that?

hwclock -u


“chronyd” is running to keep the clock syncronized. That was setup when I installed Leap 15.1. As far as I know, that is standard if you have a network connection during install.

I don’t manually run “hwclock”, but I think that is standard during either startup or shutdown. But I guess I should check that.

After weeks of going nuts,
and having to change the Win 7 clock when I boot into it,
I went in the registry and changed the ‘Real Time is Universal’ setting to 0(zero), and Win 7 boots up with the correct time.

I’m thinking Win 7 uses the system(BIOS) clock for it’s setting, and didn’t need the registry tweak.

Likely something has enabled windows sntp timeserver…

Is that a good or bad thing?
I don’t remember doing anything like that when I originally put Win 7 on this desktop
I’ll have to go looking for the NTP settings and find out how it was setup(if possible),

Hard to say, win7 is a dead OS… I would ensure it’s off and use the BIOS clock and UTC. Look for it in the date/time settings and see if it’s on.

If it is the or internet time sync you are referring to, I honestly can’t say how it is set now. I will have to check.

I do know when I had it disabled, and the registry tweak in place & set to 1, it still booted with time 5 hours difference(behind IIRC).

I will boot into Win 7 and check it, and disable it again then boot into Leap, shutdown, and RE-boot into Win 7 and see what the time/date is.
If I boot Win 7 and change the time, shutdown and restart Win 7 again, the time is correct. So I have to boot Leap between to see if it is correct or not.

If I boot Win 7 with NTP sync off, and add the registry tweak back in, It will likely boot at the 5 hour time difference.
The BIOS clock on this machine can not be set to anything other than how the BIOS is setup.(the BIOS is old and doesn’t have a later version)

PS> yeah Win 7 is ‘dead’, but every time I boot it up, there are more than a few updates out there for it. Same went for XP until MS actually stopped updating it. I think I had XP Pro for over 8 years after it’s ‘dead’ date, and they still sent out updates.

Booted win 7, disabled NTP setting, didn’t add the registry tweak back in, shut down , booted Leap and shut it down.
Booted into win 7, time was correct. Hopefully problem solved.

Hopefully :slight_smile: