Tried installing gnome shell extensions through firefox. got nothing

I’m trying to install gnome shell extensions to my fresh gnome-based installation. I’ve enabled the firefox extension and tried going to I can see the extensions, but when I click on the slider to install one I get nothing. no download.
Any ideas on how to fix this?

Hi and welcome to the forum :slight_smile:
So not even a simple extension like ?

Your using the defaults, no additional themes etc or other configuration changes?

Thanks ! :slight_smile:
Sorry, but no. The slider just keeps twirling left and right.
Nothing in the downloads folder etc.
Can it be that I’m running this installation in a virtual box machine behind a http proxy ? Hope not, as the rest of it works (web, updates etc).

Hmmm, wouldn’t think so, if your internet connection is working, all should be good.

You got the popup in firefox to allow

If you create a test user and login as the test user and try to install the extension, does the issue duplicate?

Sorry, but no difference with a brand new test user.
The installation is brand new, all defaults anyway.

Nothing under;

ls ~/.local/share/gnome-shell/

System is all up to date I’m guessing and running Firefox 47.0?

Got it ! It was the “wicked network service”. With it the firefox won’t work with “system supplied proxy settings”.
Switched to “Network Manager” in yast and then reverted firefox to use the system settings.
Now adding gnome shell extensions works :slight_smile:

Interesting, thanks for the feedback :slight_smile: