Trash issue

I downloaded some large files from video presentations and saved them to a small usb drive. When I finished watching, I tried to delete them by moving them to Trash. I get an error message that they are too big to move to trash. Didn’t see this error ever before. There seems to be a split around 20MB. Larger files won’t delete (move to trash) but smaller ones do. At one point, I went to Trash and emptied it. Some files would move there after that but not all files would. My current solution, to make the usb drive usable again was to delete the files from the command line.

Is there a setting to check to correct this behavior?

I guess we are talking here about an end-user working with a desktop (which one?)

When I as an end-user in KDE want to delete files, I use Dolphin to browse to the place they are. Then I have at least two possibilities.

  1. right click on the file name and choose “Move to Trash” from the context menu;
  2. select the file and use Shift-Delete, which will then (after showing a warning) delete it. Can also be done with a selection of several files, thus no need to fall back to the command line.

It is not quite clear to me which behavior you want to “correct”. Files too large to be stored in Trash are too large.

Again, if KDE…

Dolphin controls the overall size limit of Trash. Unless you’ve change it the default is 10% of the partition on which it resides.

(Dolphin) Settings -> Configure Dolphin -> Trash

I wasn’t aware of any file size priority in moving files to Trash, but there may well be… and if so I don’t think that can be changed, at least not from Dolphin’s GUI.

OTOH when one wants to remove all files/directories from a file system, using the CLI. cd to the mount point and use the appropriate rm command will remove all in one command. Specially with mass actions the CLI is mich more efficient then umany GUI applications.

Or in Dolphin, you can also mark the files and use “shift + delete” which will directly delete the file not moving them to trash. Of course, you should be serious not be wanting them back - just as in CLI.

Thanks for the tips!

I had forgotten about shift+delete and, of course, it worked without fail.

I didn’t know there was a Dolphin setting that limited trash file size. With the usb mounted, Dolphin showed a 10% limit for the usb as well as the ssd. The usb is 125 MB and the file limit size must be around 12 MB since I experienced that before I saw the setting in Dolphin.

What strikes me as odd is that there is no trash folder on the usb drive. Deleted files go to the trash folder on the ssd which is limited to GB in file size. So, why the lower limit of 12 MB when the trash folder on the ssd would accept a file 10 times that size? I don’t understand the throttling. Since the deleted files go to the ssd, I may as well set the trash limit (in Dolphin) to 100% for the usb. I don’t need or want to do that since shift+delete solves the problem. But it seems logical, if unnecessary.

You seem to miss some information. In random sequence.

The so called Trash of KDE (ther DEs will have similar or even same, it being subject of standards) is not a file. It is a directory: ~/.local/share/Trash. You will find there two directories: files and info.
The directory files contains all the files you moved to Trash. The directory info has for each of those files the path where it came from and the timestamp it was moved to Trash. This information suffices to move the file back to it’s original place when wanted.

Because people are lazy and thus often refuse to use their brains and clean up Trash, the result will be that the space used will grow and grow until the file system where ~/.local/share/Trash is will be full. This file system is often /home, or when there is no separate /home file system, it will be /. In both cases it being full is not something to be liked by the user her/himself, other users and the system manager. It might even result in blocking login.

When you read the above, you will understand that there is no Trash on the mounted file system that is stored on the USB device (called by you as shortcut: there is no trash folder on the USB). It is even misleading to say that there is Trash on the SSD. Trash exists on per GUI user base in that user’s home directory.
The fact that the home directory(ies) will be on a file system, and that that file system will be on some hardware mass-storage device is evident. The type of the file system (btrfs, ext4, NFS, even non-Linux), the place of the file system (partition, Logical Volume, remote, …) and the hardware at the end (connecting bus like SATA, USB, storage technique like rotating disk, SSD) has certainly nothing to do with the functioning of the Trash feature.

I do not see this. I only see one entry that can be set there (and it is based on the percentage of the /home file system although it does not explain that).

Trash as reported with usb drive plugged in.
As I stated, perhaps not too clearly, a file of 12MB when deleted from the usb drive will move to Trash on the ssd. A file larger than that will not move to the Trash on the ssd and will not delete from the usb. I delete the larger files with shift+delete or by rm from the command line.