Trash is not accessible!

This has bugged me for a while, I googled for days and have not yet found a solution.
What happened: When I click on Trash in nautilus, it shows “Sorry, could not display all the contents of “trash:///”: The specified location is not supported.”
What I did: I occasionally recover my system using backintime, I do full file system backup and recover except my home folder.
What I tried: I have Trash folder in ~/.local/share/, and I have /files and /info folders in my Trash folder. The permission is 700. I can use move to Trash from file manager, but I have to use terminal to go the ~/.local/share/files and rm to empty trash. I have tried other file manager other than nautilus, that I have the same problem, so it seems not to be the problem with the file manager. And I tried creating a new user, but the new user still cannot access to the Trash. So it seems to be some global setting.

Where is the setting that I can change the directory of my trash or get this fixed? PS: Desktop Environment: Gnome

Do you have ~/Desktop/trash.desktop and what is inside?

If you want to see what’s in that folder, open the terminal > su -> nautilus> and follow the path> /root/.local/share/Trash/files/
Here you find the files you put in the Root Trash

I use bleachbit as root to clean that folder

Why do you think the OP is talking about a trash of the root user?

That should not exist btw, because trash is typical for a desktop environment and as root you should never run a desktop environment.

Never used gnome but have had a similiar issue with kde. To resolve that I deleted the trash folder as root and the system then created a new trash folder which worked fine.

Because it’s like that, I have Gnome, and it’s always been like that.
trash: /// is like a link, and it’s trash when you start Nautilus as a super user … trust me

Hi Frank, welcome

IMO you’re missing some points here:

  • Each user has their own /home/USERNAME/.local/share/Trash,
  • This Trash-folder is for that user only.
  • If you restore things from backup, make sure that what you copy into a user’s homedir is owned by that user.

I’d like to see output of

ls -ld ~/.local/share/Trash/*


ls -lh ~/.local/share/Trash/files/

  1. you should probably not start Nautilus as superuser (but it might be a bit more acceptable then running the desktop as superuser);
  2. the OP nowhere talks about running Nautilus as superuser.

I do not have ~/Desktop/trash.desktop, should I? I only have ~/Desktop/Home.desktop

I only have one user. And Trash folder exists in my home directory.
Here is the my output:
ls -ld ~/.local/share/Trash/*
drwx------ 2 yili users 4096 Apr 8 01:08 /home/yili/.local/share/Trash/files
drwx------ 2 yili users 4096 Apr 8 01:08 /home/yili/.local/share/Trash/info

ls -lh ~/.local/share/Trash/files/
-rw-r–r-- 1 yili users 149K Apr 7 23:05 ‘Screenshot from 2018-04-07 23-05-08.png’


I tried deleted trash folder, and right click any file, select “move to Trash”, then a new trash folder was created, which I can access through terminal or manually. However, the trash menu in the left of file manager is still not accessible, same error.

Then this item in ‘Places’ does not point to something in your homedir. Right click it to remove it from the filemanager.

I can’t. Those ‘Places’ are specified in ~/.local/share/user-places.xbel. And trash is obviously a specially one that is not even showing in user-places.xbel, thats why I can’t get it fixed, because I do not know where it is configured. You can only remove those ‘Places’ added by user.

I can’t. You can only remove ‘Places’ that is added by user only…


So is it clearer?