Trash can icon shows trash but it is empty

I am not sure if this is the right place for this post. Sorry if it isn’t. I am using openSuse 11, KDE 3.5.9. My trash can shows to have trash in it but when I try to empty it I get an error that the file does not exist. Would any one be able to tell me how I might fix that? Thank you very much in advance.

In Konqueror navigate to your home Desktop, right-click on the Trash.desktop file, and choose to preview in editor. Does the file look similar to the one listed below?:

[Desktop Entry]
Comment=Contains removed files

You might also look down in /.local/share/Trash in the info and files
directories and delete any files from there.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 11:07, 2 users, load average: 0.15, 0.29, 0.33
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82

Thank you malcolmlewis & Cryovac, I tried the share folder idea first it sounded a bit faster. It worked and all is well again, at least until I manage to mess things up again. Thank you very much for your help.