Transmission - RPC web GUI not accessable through firewall

Leap 15.1

Running Transmission daemon in a “server” style set-up. Clients cannot connect to the Transmission server web GUI while the firewall is enabled. Works OK with firewall disabled.

Adding “transmission-client” to the firewall “Allowed” list with YAST gives no improvement. Unable to find what port is given by the “transmission-client” entry or how to edit it.

This document says that the “services” are supposed to come from /etc/services … which is reputedly drawn from this list. However, there is no “transmission-client” entry in this list. I can’t tell what the “transmission-client” service entry in YAST actually opens.

The needed port is 9091 which I note conflicts with the list entry for “xmltec-xmlmail” for port 9091. This might be a clue.

whenever a web browser is used to access a server, if no special non-default port is used then you have to open port 80 for unencrypted and port 443 for encrypted (SSL) connections. The IP address should be the same as the main application (Transmission in your case).

As far as IANA assigned port numbers, only the “low” port numbers up to 1024 should be considered nearly inviolate… Every port number higher than that is only a suggestion and of course if the “assigned service” isn’t running on your machine then is irrelevant and safe to use for something else.


Something must have been lost in translation because I pointed out that the Transmission GUI uses “special non-default port” 9091.

It also works fine with the firewall disabled. The problem is in the Opensuse firewall. I cannot see or edit the port for “transmission-client” service setting in YAST to determine if its correct. I also don’t see a way of easily adding services to the list.

Web pages can be viewed fine from the server box. Apache is working fine and HTML ports are being allowed, as expected.

Don’t use YaST for this - it has limited capability. Use the firewalld tools ie ‘firewall-config’ for GUI config utility or ‘firewall-cmd’ for CLI config utility.

BTW, the ‘document’ page you referred to is for SuSEfirewall2. Firewalld is what openSUSE Leap 15.x is using by default…


The message you have entered is too short. Please lengthen your message to at least 10 characters. Do you feel better now, bot? 

Editing /usr/lib/firewalld/services/transmission-client.xml to allow port 9091 for the web browser GUI interface was the solution.

That is one way of doing it…or allow port 9091 with…

sudo firewall-cmd --add-port=9091/tcp --permanent
sudo firewall-cmd --reload

Then check runt-time config with

sudo firewall-cmd --list-all