Trackers choking 3 (!) threads

I’ve taken a quick look at the system monitor and to my surprise I found out that 3 threads are consistently at 100% load even though nothing is really going on. And as I recalled similar event in the past I quickly discovered the culprit(s) - trackers (tracker-store, tracker-extract etc).
Any suggestions what’s going on and how can I tame those unruly processes? In worst case scenerio how should I remove those and what would be implications of doing it. While I’m using Xfce I also use a couple of GNOME apps (and especially Nautilus is something I’d like to keep in good running shape).

edit: I’ve also noticed that since I’ve closed trackers a load on my hard drive also lowered considerably.

Since you are using XFCE, this is easy.

Settings → Settings Manager → Session and Startup → Applications Autostart

and uncheck the boxes for everything to do with tracker.

but wouldn’t Nautilus’s search suffer if I turn of trackers? Is there a way to fix those so they wouldn’t turn into such resource hogs?

That, I don’t know.

I turn off tracker for XFCE. But if I boot into Gnome, tracker still runs there. And Gnome is the only place that I have tried Nautilus.

I’m not sure how to reduce the load. I’m not seeing much load from tracker when it runs. But perhaps that’s because my home directory is relatively small, with multimedia stuff saved elsewhere.

If you just installed then it can take some large amount of time for any tracking/search software to index your drive. This may be what you are seeing.

On the other hand all tracking software I know of sometimes goes off and does it’s own thing. :stuck_out_tongue:

And Yes searches will be slower without an indexing of the files you want to search

In Xfce, I uninstall and taboo tracker.

Searches? Install and use Recoll, I like it much better. You determine what, where, and when gets indexed.