Tracker?

When I boot into KDE 11.4. My system is very slow and I done HTOP and discovered something called tracker running. It’s eating up all my resources. What is it, do I need it and how do I disable it.

Cheers.

This is Tracker.

On Mon, 11 Jul 2011 12:06:03 +0000, chrispche wrote:

> When I boot into KDE 11.4. My system is very slow and I done HTOP and
> discovered something called tracker running. It’s eating up all my
> resources. What is it, do I need it and how do I disable it.
>
> Cheers.

It’s apparently the new desktop search tool. There are other threads
here about it where it’s suggested that to deal with the performance
issue, you might uninstall it.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Maybe you should be patient for a while - a desktop indexer does take quite some ressources when building its database. After that, it will only peak for a short time each time a new session is started. You might also try to take a look into Trackers settings; I think it’s wise to mark only certain needed directories to be indexed.

In case you do not need an indexer anyway, you should follow Jims hint and just deactivate / uninstall it.

Sorry for being a little thick here, where do I find the settings for the thing. Again I say I’m using openSUSE 11.4 64bit KDE 4.6.

Thanks.

PS Sorry for noobyness of this, I should know. However I have been a long time Gnome user and have only just converted to KDE. Where in KDE can you find Startup Applications, so I can disable what I don’t use. In Gnome is was called Startup Applications or something and you could sort it all out from there.

On 07/11/2011 05:36 PM, chrispche wrote:
>
> so I can disable what I don’t use.

i have no idea how to disable it, but to uninstall, just

-open YaST > Software Management
-search on ‘tracker’ you will get a list of stuff in the right pane,
find the single word ‘tracker’
-right click on it and pick “Delete”
-then click on Options and select “Cleanup when deleting packages”
-click on “Accept”
-job done


DD
-Caveat-Hardware-Software-

In the KDE menus:

System → Configuration → Search and indexing.

That appears to be the settings for tracker.

I could not find a way of preventing tracker from starting in gnome. However, I could configure it to search very few directories and do so as slowly as possible.

I was able to turn off tracker in XFCE, and after doing that it no longer runs in KDE. It still runs in gnome.

Now I would like to find a way of stopping akonadi from running :frowning:
Well, okay, I can turn off akonadi in .config/akonadi/akonadiserverrc (and have done so)

I had the same problem. But I can’t remember exactly what I did.
Try “man tracker” or “apropos tracker” in the shell. That should
point you to a configuration file. This can be edited quite
easily since it contains a lot of comments. I think it is located
somewhere in a subdir of the ./config subdir of your
home dir.

hope that helps

Hi:
By configuring tracker, running “tracker-preferences”, it is in principle possible to reduce the time seized by tracker but not at an acceptable minimum, therefore I deleted it. Now I have the problem that several important applications reinstall tracker!
Thanks.