Tracker Extractor miner segfault in Gnome 3.12

I’ve recently upgraded from Gnome 3.10 (from an openSUSE 13.1 ‘stock’ installation) to 3.12 using the GNOME:/STABLE:/3.12/openSUSE_13.1/ repo, everything went well but gnome-music doesn’t find any of my music files.

After some investigation I discovered it was because the Extractor miner in tracker was segfaulting during indexing, /var/log/messages reports this:

2014-08-15T19:12:44.573702+01:00 camsLaptop kernel:   237.214035] mpegaudioparse0[2094]: segfault at 48 ip 00007fdbe164e42a sp 00007fdbc7dbf480 error 6 in[7fdbe1633000+44000]

Now it should be noted that I selected the ‘Switch installed packages to the versions in this repository’ option for the Gnome 3.12 repo, so I’m now using gstreamer 1.2.4 but the version of fluendo has not changed (is fluendo even used for reading metadata?). I also tried switching installed packages to PackMan to pick up gstreamer 1.4, but it made no difference.

I performed a tracker-control hard reset between each attempt, upon starting it again I tried setting the verbosity level to detailed so I could see which file was causing the fault, but I got the below information and then nothing changed in the output:

tracker-control -s --set-log-verbosity=detailed
Setting log verbosity for all components to 'detailed'…

  Store    : detailed
  Extract  : detailed
  Writeback: detailed

Miners (Only those with config listed):
  Files    : detailed

Starting miners…
  ✓ File System
  ✓ Applications
  ✓ Extractor

Has anyone had a similar experience?