TP Link wireless card

I have just installed the SUSE 11.0 from DVD (also I am new tu linux)
My wireless card is TPlink TL-WN510G_550G_551G and it does not work.

with the instructions provided from sticky masage I got the following:

02:05.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
///////////////////////////////////////////////////////////////////////////

02:05.0 0200: 168c:001a (rev 01)

//////////////////////////////////////////////////////////////////////////

ath5k phy0: Atheros AR5213A chip found (MAC: 0x78, PHY: 0x45)
ath5k phy0: RF2112A 2GHz radio found (0x56)

//////////////////////////////////////////////////////////////////////////////////

lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

This is as far as I could get I gues from the explenation that I am missing the driver?

Please tell me what should I do nex and if I have corectly recognised My wireles car from the comand lines?

As you just started with openSUSE, I would suggest that you download the 11.1 media and
start over. There is a world of difference between wireless networking in the 2.6.25
kernel (11.0) and 2.6.27 (11.1).

Larry