Touchpad works but "Not touchpad found in settings"

Hi! New OpenSuse user here. I just moved from Arch.

I have a small problem with touchpad. It seems to work fine, however, when I go to Touchpad settings (KDE) there is “No touchpad found”.
Now, few questions:

  1. Which driver is OpenSuse using? I see both xf86-input-synaptics and xf86-input-libinput packages installed.
  2. If both are installed how can I determine which one is being used?
  3. What can be cause of KDE settings not detecting touchpad? How can I debug it?

The laptop is Dell Lattitude 7480. All packages are up to date.


When I got a laptop in 2009, I ran into a similar problem with openSUSE 11.3. But now it works fine with newer openSUSE releases.

I think your touchpad is being recognized as a generic PS2 mouse, or something similar. So it still works, but without full functionality because it is not recognized as a touchpad.

Suggestion: Download the iso for live KDE Tumbleweed. And test that. If the touchpad works properly there, then you might be able to getting it working on Leap 42.3 with a newer kernel. You can get newer kernels here

Just add that as a repo. You can disable the repo if you don’t want to continually update to the newest kernel there, and just enable it briefly when you want to check or install a newer kernel.

As for drivers: If you have both installed, then I’m pretty sure that “xf86-input-synaptics” is being used. I had to uninstall that one, to force the use of “xf86-input-libinput”. And note that the synaptics driver worked well with KDE, but not so well with Gnome. The libinput driver seems to work with both KDE and Gnome, but I’m really not an expert on that. For me, a touchpad driver works fine if it allows me to disable the touchpad.

If Tumbleweed works for your touchpad, then you might also want to try Leap 15.0 Beta. If the touchpad works with 15.0, it might be easier to just install that. The final release of 15.0 is expected near the end of May. You can find a live KDE iso for 15.0 Beta HERE.

Yeah, that could be the issue.
If I look on

**rskolasinski@gilbert:~> **xinput list                                                                                                                                                                                                          
⎡ Virtual core pointer                          id=2    [master pointer  (3)]                                                                                                                                                                
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]                                                                                                                                                                
⎜   ↳ DLL07A0:01 044E:120B                      id=12   [slave  pointer  (2)]                                                                                                                                                                
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]                                                                                                                                                                
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]                                                                                                                                                                
    ↳ Power Button                              id=6    [slave  keyboard (3)]                                                                                                                                                                
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]                                                                                                                                                                
    ↳ Power Button                              id=8    [slave  keyboard (3)]                                                                                                                                                                
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]                                                                                                                                                                
    ↳ Integrated_Webcam_HD                      id=10   [slave  keyboard (3)]                                                                                                                                                                
    ↳ Integrated_Webcam_HD                      id=11   [slave  keyboard (3)]                                                                                                                                                                
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]                                                                                                                                                                
    ↳ Dell WMI hotkeys                          id=14   [slave  keyboard (3)]                                                                                                                                                                
    ↳ DLL07A0:01 044E:120B                      id=15   [slave  keyboard (3)] 

I don’t see any touchpad devices… Same laptop on Manjaro has no problems.

Manjaro probably has a newer kernel than Leap 42.3. That’s why I suggest experimenting with live Tumbleweed or live Leap 15.0 beta.

Yeah, indeed it is the case. On Tumbleweed Live USB it detects touchpad without problems.

This is the touchpad device…

DLL07A0:01 044E:120B                      id=12   [slave  pointer  (2)] 

Yeah, indeed it is the case. On Tumbleweed Live USB it detects touchpad without problems.

For new hardware like this, trying a newer kernel is often worth a shot. If you want to use Leap, you can still get the required kernel support by installing the current stable kernel as Neil mentioned already.

Yes, the controls for the touchpad are a little difficult to find - it took me a couple of days as well,:shame:
I’ll try to post some screenshot ( three of them ), which should solve your problem. Can’t post pictures… Sorry,

Click on “APPLICATION MENU” in the lower left hand corner.
Click on the “CONFIGURE DESKTOP” icon along the left side of the pop up menu.
Go to the “HARDWARE” section in the SYSTEM SETTINGS window and Click on the “INPUT DEVICES” icon,

And there you are.

@xenrobia: No, that wasn’t the issue the OP was having. When the device is not recognised as a touchpad device then ‘No touchpad found’ is displayed and the touchpad controls are greyed out. In this case using a more recent kernel allows the touchpad to be handled correctly. Not a KDE issue at all.

Okay deano, my mistake: I should have paid more attention to what the OP was actually saying.

Thanks, Rob