Touchpad recognized but still inactive

Hi, I have a Toshiba satellite c50d and i can’t enable the trackpad, i’ve tried to see

/usr/sbin/hwinfo --mouse

and reports:

43: PS/2 00.0: 10500 PS/2 Mouse
[Created at input.249]
Unique ID: AH6Q.5+smWHVjPI3
Hardware Class: mouse
Model: “AlpsPS/2 ALPS GlidePoint”
Vendor: 0x0002
Device: 0x0008 “AlpsPS/2 ALPS GlidePoint”
Compatible to: int 0x0210 0x0003
Device File: /dev/input/mice (/dev/input/mouse0)
Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event1, /dev/input/by-path/platform-i8042-serio-4-event-mouse, /dev/input/by-path/platform-i8042-serio-4-mouse
Device Number: char 13:63 (char 13:32)
Driver Info #0:
Buttons: 3
Wheels: 0
XFree86 Protocol: explorerps/2
GPM Protocol: exps2
Config Status: cfg=no, avail=yes, need=no, active=unknown

And with the usb optical mouse:

41: USB 00.0: 10503 USB Mouse
[Created at usb.122]
Unique ID: ADDn.HY8uWEBN5_B
Parent ID: k4bc._63LoM0erv2
SysFS ID: /devices/pci0000:00/0000:00:10.0/usb1/1-1/1-1:1.0
SysFS BusID: 1-1:1.0
Hardware Class: mouse
Model: “Trust International B.V Optical Mouse”
Hotplug: USB
Vendor: usb 0x15d9 “Trust International B.V.”
Device: usb 0x0a4d “Optical Mouse”
Revision: “1.00”
Compatible to: int 0x0210 0x0013
Driver: “usbhid”
Driver Modules: “usbhid”
Device File: /dev/input/mice (/dev/input/mouse1)
Device Files: /dev/input/mice, /dev/input/mouse1, /dev/input/event2, /dev/input/by-id/usb-15d9_USB_OPTICAL_MOUSE-event-mouse, /dev/input/by-path/pci-0000:00:10.0-usb-0:1:1.0-event-mouse, /dev/input/by-id/usb-15d9_USB_OPTICAL_MOUSE-mouse, /dev/input/by-path/pci-0000:00:10.0-usb-0:1:1.0-mouse
Device Number: char 13:63 (char 13:33)
Speed: 1.5 Mbps
Module Alias: “usb:v15D9p0A4Dd0100dc00dsc00dp00ic03isc01ip02in00”
Driver Info #0:
Buttons: 3
Wheels: 1
XFree86 Protocol: explorerps/2
GPM Protocol: exps2
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #40 (Hub)

44: PS/2 00.0: 10500 PS/2 Mouse
[Created at input.249]
Unique ID: AH6Q.5+smWHVjPI3
Hardware Class: mouse
Model: “AlpsPS/2 ALPS GlidePoint”
Vendor: 0x0002
Device: 0x0008 “AlpsPS/2 ALPS GlidePoint”
Compatible to: int 0x0210 0x0003
Device File: /dev/input/mice (/dev/input/mouse0)
Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event1, /dev/input/by-path/platform-i8042-serio-4-event-mouse, /dev/input/by-path/platform-i8042-serio-4-mouse
Device Number: char 13:63 (char 13:32)
Driver Info #0:
Buttons: 3
Wheels: 0
XFree86 Protocol: explorerps/2
GPM Protocol: exps2
Config Status: cfg=no, avail=yes, need=no, active=unknown

Which desktop environment are you using? Have you tried using the touchpad without the mouse plugged in? For example, with KDE it is possible to configure so that the touchpad is disabled when the mouse is plugged in:

System Settings > Hardware > Input Devices > Touchpad

If this isn’t the case, then check /var/log/Xorg.0.log to see how the touchpad is being handled (which Xorg input driver being used, errors etc). It’s a lengthy file, so if you want to share it upload it to http://paste.opensuse.org/ and post the URL that it generates here so that we can review it.

Also to see the Xorg drivers in use, use something like the following to filter

grep 'Using input driver' /var/log/Xorg.0.log

This will a list of input devices found and whether drivers are being used or not for those devices

grep 'input' /var/log/Xorg.0.log

Thank you very much! i uploaded the log text SUSE Paste

and

29.917] (II) Using input driver 'evdev' for 'Power Button'
29.969] (II) Using input driver 'evdev' for 'Video Bus'
29.972] (II) Using input driver 'evdev' for 'Power Button'
29.975] (II) Using input driver 'evdev' for ' USB OPTICAL MOUSE'
30.030] (II) Using input driver 'evdev' for 'TOSHIBA Web Camera - HD'
30.033] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
30.035] (II) Using input driver 'synaptics' for 'AlpsPS/2 ALPS GlidePoint'

21758.234] (II) Using input driver ‘evdev’ for ’ USB OPTICAL MOUSE’
21853.776] (II) Using input driver ‘evdev’ for ’ USB OPTICAL MOUSE’
21897.307] (II) Using input driver ‘evdev’ for ’ USB OPTICAL MOUSE’
22391.377] (II) Using input driver ‘evdev’ for ’ USB OPTICAL MOUSE’
24534.800] (II) Using input driver ‘evdev’ for ’ USB OPTICAL MOUSE’
24602.149] (II) Using input driver ‘evdev’ for ’ USB OPTICAL MOUSE’

You didn’t answer the question about which desktop you’re using, and whether removing the USB-connected mouse then allows the touchpad to activate.

i’m using KDE, especially Kwin, i found out this using wmctrl

Name: KWin
Class: N/A
PID: N/A
Window manager’s “showing the desktop” mode: OFF

and with ** echo $XDG_CURRENT_DESKTOP **it says KDE.

The track-pad remain inactive even without usb optical mouse

What does the following report about the touchpad status?

synclient -l |grep Touchpad

If it reports ‘TouchpadOff=1’ then you could try re-enabling with

synclient TouchpadOff=0

If it is already reported as enabled, then a bug report may need to be submitted perhaps.

Alternatively, you could try using the libinput driver (rather than the synaptics driver currently in use). No promises that it will work though. If it is installed it will take precedence AFAIU. Install it with

sudo zypper in xf86-input-libinput

then restart the X-server with CTRL+ALT+Backspace (twice). You can confirm which Xorg driver is in use for the touchpad using

grep 'Using input driver' /var/log/Xorg.0.log

If it doesn’t work or you don’t want to use it for some other reason, then you can remove it with

sudo zypper rm xf86-input-libinput

The Touchpadoff is equal to 1; i’ve tried the new drivers but still no trackpad…maybe it’s hardware problem? there’s a way to check?

10120.992] (II) Using input driver ‘libinput’ for ‘Power Button’
10121.053] (II) Using input driver ‘libinput’ for ‘Video Bus’
10121.067] (II) Using input driver ‘libinput’ for ‘Power Button’
10121.102] (II) Using input driver ‘libinput’ for ’ USB OPTICAL MOUSE’
10121.240] (II) Using input driver ‘libinput’ for ‘TOSHIBA Web Camera - HD’
10121.262] (II) Using input driver ‘libinput’ for ‘AT Translated Set 2 keyboard’
10121.283] (II) Using input driver ‘libinput’ for ‘AlpsPS/2 ALPS GlidePoint’
10334.748] (II) Using input driver ‘libinput’ for ’ USB OPTICAL MOUSE’

Sometimes when i log in after the stop (closing thelaptop), the mouse optical mouse doesn’t work too, i have to switch the usb port…

Well, that means the device is disabled. Did you try to enable it as explained previously so that ‘TouchpadOff=0’?

i’ve tried the new drivers but still no trackpad…maybe it’s hardware problem? there’s a way to check?

Well, you could try an alternative live distro (on a USB memory stick for example). Check if the touchpad is working via the other distro.

The advice given here might be worth trying too…

Shift plus F5 should fix it’.

No sorry, i’m a fuc**ing dump! the TouchpadOff was equal to 0; i’ll try in another distribution to try if it works, i’ll make a bootable usb! Thanks for your time! We will see

I think that it’s gone! I’ve tried with win7 and nothing…it’s dead! Thanks anyway for your help! I have another problem, if it’s not pertinent i’ll open another thread, but often after the stop of my computer, the keyboard (always) and the mouse optical (sometimes) stop working; for the mouse i can simply change the usb port, but for the keyboard i have to close the laptop, wait for the suspension, and then re-open; it’s very unpleasant! May i do something?

Thanks

Hardware failure - well at least you know now.

For the other issues you mention, you’re best advised to start a new thread with suitable title to catch the attention of others who can help.

Thank you very much!!:wink: