Touchpad problems with lenovo T61

I have a Lenovo T61 that came with Suse 10. I installed Suse 11 and the touch pad worked for a few days now it no longer does. The touch pad is functional as soon as the mouse appears on screen. Once the Desktop loads, it stops functioning.

It worked perfectly fine with v10, i can not figure out the problem now… strangest part was, it worked for a few days with v11… and then poof… it stopped

any help would be great

thank you all for you time in advance!

hi!
you’re using kde or gnome? usb-mouse works?
check if mouse and touchpad are configured properly in Sax2.
check if ‘SHMConfig’ value in ‘Input device’ section of /etc/X11/xorg.conf is:

Option          "SHMConfig"       "on"

if you’re using gnome and usb-mouse works, go to control panel>sessions, uncheck ‘touchpad’, reboot, and see if it helps.

Thanks, disabling the touchpad in sessions worked for me.
It was strange though, the touchpad stopped working after I had restarted from the previous night when it worked just fine. Anyway thank you very much.