Touchpad problem after using external mouse


I am using HP Pavilion dv6000 and its working fine except this issue I am facing these days. I am using an external mouse from last few weeks and locked my touchpad while using external mouse. Now when I start/boot my laptop, after login it takes few minutes touchpad to get working. Also I need to enable/disable touchpad 2-3 times, then only my touchpad get active and the mouse pointer starts moving using touchpad. One more thing is that before login (I mean on login screen) the mouse works fine and I can click and move mouse pointer easily.

Could anyone help me to get out of this problem.

I’m having similar problems on my Acer Aspire 1640. The touchpad worked fine until a couple of days ago. It just suddenly stopped letting me move the cursor after I log in. During boot its fine but once I have a desktop it stops responding. However the scroll zones and buttons do respond. This started without any external mouse having been used for a few days at least. I tried reinstalling the synaptics packages to no avail, I’m stumped.