Touchpad on HP Pavilion g6

Hi all,

I’m testing out opensuse 12.1 on this laptop and everything works great except for my touchpad. The touchpad sometimes doesn’t initialize and when it does I get frequent touchpad quirkyness, ie. stops working, or freezes for a few seconds.

When this happens I get messages like these in the syslog:

psmouse.c: TouchPad at isa0060/serio4/input0 lost sync at byte 1
psmouse.c: bad data from KBC - timeout
psmouse.c: bad data from KBC - bad parity
psmouse.c: TouchPad at isa0060/serio4/input0 - driver resynched.
psmouse.c: Failed to enable mouse on isa0060/serio4

The 1st one is the one that I get most of the time but sometimes the others show up too. I haven’t tried that much in opensuse yet to solve the problem but in Debian/Ubuntu I’ve tried many different kernel versions, a few kernel flags, and some options with synclient. But nothing seems to help.

From what I’ve read it seems to be either a bug in the kernel or in the synaptics driver.

Has anyone else solved this or does anyone have any creative suggestions to try?