touchpad on dell latitude e6510

my touchpad doesn’t works well, I can click move cursor but scrolling doesn’t work at all
I installed the new kernel (more easy than a newby like me expected also for nvidia driver in the hard way ;):))
hoping to have my touchpad working, is there any chance to have my touchpad working better?

suse 11.3
kde 4.5.9 (4.6rc2)
gsynaptics 0.9.16-7.1
synaptiks 0.4.99svn-25.1
kernel 2.6.37-40-desktop
laptop dell latitude e6510

info from windows
touchpad alps electric
i8042prt

taking the same info as from here

and I found also this:

pla@linux-y7c9:~> dmesg | grep PS/2
    1.921775] PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
    1.923710] mice: PS/2 mouse device common for all mice
    6.220011] input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input1
pla@linux-y7c9:~> 

pla@linux-y7c9:~> dmesg | grep 8042
    1.922035] i8042.c: Warning: Keylock active.
    1.923625] serio: i8042 KBD port at 0x60,0x64 irq 1
    1.923631] serio: i8042 AUX port at 0x60,0x64 irq 12
    1.924584] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input0
    6.220011] input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input1
   14.804270] input: HDA Intel Mic at Ext Right Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
pla@linux-y7c9:~> 

pla@linux-y7c9:~> hal-device | grep -B 15 input.x11_driver
.....only things containing 8042
35: udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input'
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'input'  (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port'  (string)
  info.subsystem = 'input'  (string)
  info.product = 'PS/2 Generic Mouse'  (string)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio1/input/input1/event1'  (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port'  (string)
  input.product = 'PS/2 Generic Mouse'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input'  (string)
  info.capabilities = { 'input', 'input.mouse' } (string list)
  input.x11_driver = 'evdev'  (string)
--
  info.category = 'input'  (string)

36: udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'input'  (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  input.keymap.data = { 'e001:playpause', 'e002:stopcd', 'e003:previoussong', 'e004:nextsong', 'e005:brightnessdown', 'e006:brightnessup', 'e007:battery', 'e008:wlan', 'e009:ejectclosecd', 'e00a:suspend', 'e00b:switchvideomode', 'e00f:switchvideomode', 'e010:previoussong', 'e011:prog1', 'e012:media', 'e013:f23', 'e015:camera', 'e00c:f23', 'e019:nextsong', 'e01b:switchvideomode', 'e022:playpause', 'e024:stopcd', 'e06d:media' } (string list)
  info.subsystem = 'input'  (string)
  info.product = 'AT Translated Set 2 keyboard'  (string)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio0/input/input0/event0'  (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  input.product = 'AT Translated Set 2 keyboard'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'  (string)
  info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'input.keymap', 'button' } (string list)
  info.addons.singleton = { 'hald-addon-input' } (string list)
  input.x11_driver = 'evdev'  (string)

from here

I found and modified this:

  1. Patch src/drivers/input/mouse/alps.c

static const struct alps_model_info alps_model_data] = {

  • { { 0x73, 0x02, 0x64 }, 0xcf, 0xcf, ALPS_PASS | ALPS_DUALPOINT | ALPS_PS2_INTERLEAVED }, /* Dell Latitude E6510 /
    { { 0x32, 0x02, 0x14 }, 0xf8, 0xf8, ALPS_PASS | ALPS_DUALPOINT }, /
    Toshiba Salellite Pro M10 /
    { { 0x33, 0x02, 0x0a }, 0x88, 0xf8, ALPS_OLDPROTO }, /
    UMAX-530T */
    { { 0x53, 0x02, 0x0a }, 0xf8, 0xf8, 0 },

but in suse 11.3 is here:
/usr/src/linux-2.6.37-40/drivers/input/mouse/
and there is alps.c and alps.h, I modified alps.c, is it ok??

now I a doubt:
can I run this command? becouse psmouse.ko there isn’t in suse 11.3 in
/usr/src/linux-2.6.37-40/drivers/input/mouse/

  1. Compile psmouse.ko module

cd src/drivers/input/mouse
make -C /lib/modules/uname -r/build M=pwd psmouse.ko

Hi,

Have you installed and tried ‘synaptiks’ (kde) or ‘gsynaptics’ (gnome).

On an HP 625 laptop it allows most parameters of the touchpad to be adjusted. It’s part of the obs://build.

Edit: Read http://forums.opensuse.org/english/get-technical-help-here/laptop/444766-opensuse-11-3-dell-lattitude-e6510-touchpad-not-working-propperly.html?highlight=touchpad+dell+latitude+e6510 for solution!

yes both, last version of everything:
suse 11.3
kde 4.5.9 (4.6rc2)
gsynaptics 0.9.16-7.1
synaptiks 0.4.99svn-25.1
kernel 2.6.37-40-desktop

I will try that solution too :slight_smile:

added i8042.nopnp in bootloader, don’t works :frowning:

You should not need both gsynaptics and synaptiks installed.

As you are using kde then synaptiks is all that is required.

Can you disable the touchpad via synaptiks?

:slight_smile: I need both becouse I use kde and gnome, I cannot disable anything via synaptiks via system settings becouse this error:
Warning: Touchpad configuration is not supported on this system. The synaptics driver is either not loaded or too old. Refer to the documentation for information about the required driver version.

Hi pier_andreit,

news is not good!

You have hit a kernel bug. See “[Bug 662003] New: Touchpad in Dell Latitude E6510 is not recognise by OS”.
This has not yet been resolved for openSUSE11.4 M5 or M6

Don’t shoot the messenger

Michael

In the KDE Configure Desktop (System Settings) –> Hardware –> Input Devices –> Touchpad, what do you have for scrolling options ? Particularly, the vertical scrolling : sometimes it is set for two fingers. Also, check the “General” tab, “touchpad state at startup” option.

The good news is that somebody more clever than me in coding has the same problem :slight_smile:
from your link I jumped here and at #249 Steven says:

------ I still cannot disable the touchpad altogether, but vertical
scrolling works (not horizontal)-----

this for me should be enough, the lack of scrolling is quite annoyng:)
he referes to this #248:

-------# install psmouse 0.2.1-all for vertical scrolling:

sudo apt-get install dkms
cd ~
wget https://bugs.launchpad.net/ubuntu/+source/linux/+bug/550625/+attachment/1797114/+files/psmouse-0.2-1.all.deb
sudo dpkg -i psmouse-0.2-1.all.deb
rm psmouse-0.2-1.all.deb
sudo reboot-------

but everything is related to ubuntu, how can I do the same in suse??

;)Only in Sparta messengers are shooted, we only usually shoot at piano players;)

I cannot access to (System Settings) –> Hardware –> Input Devices –> Touchpad, it gives me this error:

Warning: Touchpad configuration is not supported on this system. The synaptics driver is either not loaded or too old. Refer to the documentation for information about the required driver version. 

Hi pier_andreit,

As I understand the situation your touchpad is seen as a mouse by the OS.

Does changing the mouse settings have any effect?
(System Settings) → Hardware → Input Devices → Mouse

One other possibility: do you see a (System Settings) –> Lost and Found ? On 11.3 and early 11.4, the Touchpad would (occasionally) show up under “Lost and Found” –> Touchpad.

Failing this, the earlier-referenced bug is most likely your problem. While I do not have a Dell e6510, my Gateway NV79 shared the same display/Intel Graphics/eDp problem that were originally reported against the Dell models (e6510 and others).

May be good news,gentoo people seems solved the problem
https://bugs.gentoo.org/show_bug.cgi?id=318567
has we any idea what happens in suse?? in the 12.1rcx??? veryclose to come :slight_smile:

OooooooK it works!! :slight_smile:
https://bugzilla.novell.com/show_bug.cgi?id=716852
on my dell latitude e6510 I installed opensuse 12.1 rc1, updated the kernel from this repository:
Index of /repositories/home:/namtrac:/branches:/Kernel:/HEAD/openSUSE_Factory
by yast, rebooted, and everything works, scroll, two fingers etc.
I hope it will be in 12.1 final release :slight_smile:
thanks amazing team :-))

Great. That’s one of the reason’s I will be an early adopter of 12.1. I have already moved to 12.1 rc1 on my laptop - the one where the touchpad had problems under 11.4 . It is mostly working pretty well. I will install the 12.1 final release when that is out.

I think it is really the kernel development team that did the main work here. The opensuse team also deserve thanks, because they are keeping up to date with the newer kernels.

On 10/30/2011 11:56 AM, nrickert wrote:
>
> pier_andreit;2398853 Wrote:
>> OooooooK it works!! :slight_smile:
> Great. That’s one of the reason’s I will be an early adopter of 12.1.
> I have already moved to 12.1 rc1 on my laptop - the one where the
> touchpad had problems under 11.4 . It is mostly working pretty well. I
> will install the 12.1 final release when that is out.
>
> I think it is really the kernel development team that did the main work
> here. The opensuse team also deserve thanks, because they are keeping
> up to date with the newer kernels.

BTW, that Gentoo fix was for kernel 2.6.33, which is ANCIENT by kernel
standards. There have been 8 new releases since then, and it is not surprising
that the problem has been fixed since then. Note that 8 releases is on the order
of 2 years.

may be the first try or success, but the last message with working situation is Sven Eden 2011-10-18 20:09:24 UTC