touchpad not working on Dell laptop


I have me a lovely new Dell laptop: Inspiron 3000 series (model x510404au), i7 processor, 8 Gig RAM, 1 TB HDD.

I have installed openSUSE 13.1 in a dual-boot configuration with Win 8.1. The touchpad works fine in Windows, but is as dead as a doorknob in Linux. Upon login I get a “touchpad not detected” message:

No touchpad found 
No touchpad was found in this system. If the system has a touchpad, please make sure that the synaptics driver is properly installed and configured. 
 If your touchpad is not found, though the driver is installed and configured correctly, please compile detailed information about your touchpad hardware and report this issue to the issue tracker](

I am using linux quite happily with a USB mouse but would like to get the touchpad working. Google hasn’t been much help to me. Hence I turn to the experts for advice :slight_smile:

Following is the output from various diagnostic commands.

/usr/sbin/hwinfo --mouse

25: USB 00.0: 10503 USB Mouse                                   
  [Created at usb.122]
  Unique ID: dwDZ.sGFjMJXxze9
  Parent ID: ADDn.Wkj53szWOaA
  SysFS ID: /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.0
  SysFS BusID: 1-1.3:1.0
  Hardware Class: mouse
  Model: "Microsoft Wheel Mouse Optical"
  Hotplug: USB
  Vendor: usb 0x045e "Microsoft Corp."
  Device: usb 0x0040 "Wheel Mouse Optical"
  Revision: "3.00"
  Compatible to: int 0x0210 0x0013
  Driver: "usbhid"
  Driver Modules: "usbhid"
  Device File: /dev/input/mice (/dev/input/mouse0)
  Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event5, /dev/input/by-id/usb-Microsoft_Microsoft_3-Button_Mouse_with_IntelliEye_TM_-event-mouse, /dev/input/by-path/pci-0000:00:1d.0-usb-0:1.3:1.0-event-mouse, /dev/input/by-id/usb-Microsoft_Microsoft_3-Button_Mouse_with_IntelliEye_TM_-mouse, /dev/input/by-path/pci-0000:00:1d.0-usb-0:1.3:1.0-mouse
  Device Number: char 13:63 (char 13:32)
  Speed: 1.5 Mbps
  Module Alias: "usb:v045Ep0040d0300dc00dsc00dp00ic03isc01ip02in00"
  Driver Info #0:
    Buttons: 3
    Wheels: 1
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #33 (Hub)

cat /proc/bus/input/devices

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/devices/platform/i8042/serio0/input/input0
U: Uniq=
H: Handlers=sysrq kbd event0 
B: EV=120013
B: KEY=1100f02902000 8380307cf910f001 feffffdfffefffff fffffffffffffffe
B: MSC=10
B: LED=7

I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input1
U: Uniq=
H: Handlers=event1 
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=PNP0C0C/button/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input2
U: Uniq=
H: Handlers=kbd event2 
B: EV=3
B: KEY=10000000000000 0

I: Bus=0019 Vendor=0000 Product=0003 Version=0000
N: Name="Sleep Button"
P: Phys=PNP0C0E/button/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input3
U: Uniq=
H: Handlers=kbd event3 
B: EV=3
B: KEY=4000 0 0

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=LNXPWRBN/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input4
U: Uniq=
H: Handlers=kbd event4 
B: EV=3
B: KEY=10000000000000 0

I: Bus=0003 Vendor=045e Product=0040 Version=0110
N: Name="Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)"
P: Phys=usb-0000:00:1d.0-1.3/input0
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.3/1-1.3:1.0/input/input5
U: Uniq=
H: Handlers=mouse0 event5 
B: EV=17
B: KEY=70000 0 0 0 0
B: REL=103
B: MSC=10

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=LNXVIDEO/video/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:07/LNXVIDEO:00/input/input6
U: Uniq=
H: Handlers=kbd event6 
B: EV=3
B: KEY=3e000b00000000 0 0 0

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=LNXVIDEO/video/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:01/input/input7
U: Uniq=
H: Handlers=kbd event7 
B: EV=3
B: KEY=3e000b00000000 0 0 0

I: Bus=0010 Vendor=001f Product=0001 Version=0100
N: Name="PC Speaker"
P: Phys=isa0061/input0
S: Sysfs=/devices/platform/pcspkr/input/input8
U: Uniq=
H: Handlers=kbd event8 
B: EV=40001
B: SND=6

I: Bus=0019 Vendor=0000 Product=0000 Version=0000
N: Name="Dell WMI hotkeys"
P: Phys=wmi/input0
S: Sysfs=/devices/virtual/input/input9
U: Uniq=
H: Handlers=kbd event9 rfkill 
B: EV=13
B: KEY=1500b00000000 200300000 0 0
B: MSC=10

I: Bus=0003 Vendor=0c45 Product=670b Version=3262
N: Name="Integrated_Webcam_HD"
P: Phys=usb-0000:00:1d.0-1.5/button
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.5/1-1.5:1.0/input/input10
U: Uniq=
H: Handlers=kbd event10 
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel MID HDMI/DP,pcm=8"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:03.0/sound/card0/input11
U: Uniq=
H: Handlers=event11 
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel MID HDMI/DP,pcm=7"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:03.0/sound/card0/input12
U: Uniq=
H: Handlers=event12 
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel MID HDMI/DP,pcm=3"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:03.0/sound/card0/input13
U: Uniq=
H: Handlers=event13 
B: EV=21
B: SW=140

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="HDA Intel PCH Front Headphone"
P: Phys=ALSA
S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card1/input14
U: Uniq=
H: Handlers=event14 
B: EV=21
B: SW=4

xinput list

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)    id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=12   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=14   [slave  keyboard (3)]


Couldn't find synaptics properties. No synaptics driver loaded?

The packages synaptiks and xf86-input-synaptics are both installed and up to date.

I have tried twiddling with the checkbox enabling the touchpad daemon in
Configure Desktop / Startup and Shutdown / Service Manager / KDE Touchpad
but to no avail.

Any help will be appreciated.

I can’t really help. But I’ll report what happened to me.

I bought a Dell laptop around Dec 2009. And the touchpad didn’t work properly with linux.

But now it works great.

What is probably happening, is that you have newer hardware that is not yet supported by today’s linux. But wait a year, and it probably will be supported.

You may need to update the kernel.
I would update the kernel 3.11x to kernel 3.15x and mkinitrd. (The kernel 3.16.rc6 is also available which you can try should this one not work).

Add this kernel 3.15.6x repository to Yast Software Repositories
Update kernel, mkinitrd, kernel-sources and kernel-syms.

Shutdown and restart your laptop. Rerun your other tests to detect the touchpad.

Follow Up

Interesting read on configuring your touchpad from Archwiki
More help is available by open konsole or xterm and typing:

man synaptics


hi Blinky,


after some updates the mouse or touchpad does not function correctly

running the command ‘synaptics’ (without quotes),
from within a terminal, sorts things out

its then possible to personalise with -System Settings, --Input Devices


We are presently using xf86-input-synaptics-1.7.1-2.1.2.x86_64.
However, an updated version of xf86-input-synaptics-1.8.0-48.5.x86_64.rpm is now available for installation.

Here’s the link to the latest X11-Xorg repository to add to Yast:

Thanks all for your replies.

Romanator, I have added the Xorg repository you mention above and have attempted to install the latest version of xf86-input-synaptics but YaST suggests that both xf86-input-evdev-* and xf86-video-vesa-* will be broken by this. One of the conflict-resolution options suggested is to install xorg-x11-server-* from obs:// Is this the right option to take?

Thanks again

Yes. The server package xorg-x11-server-* from obs:// must also be updated.
Don’t forget to reboot your laptop after the update.

Good Luck!

Well I upgraded the synaptics package to the most recent version, as suggested …

… and the touchpad is STILL not recognised. I still get the “no touchpad found on this system” dialog upon login.

Guess I need to wait for the drivers to catch up with the hardware.

So I tried updating the kernel too: installed 3.15.6-2.1.gedc5ddf from Plus the sources, debug, mkinitrd, etc.

This fails to boot! I get a message about a bad signature and am told that I need to load the kernel … ?!?

Fortunately I can boot to the old kernel via the advanced options menu on grub. How to get the new kernel working - or roll back to the old one?

You probably have a UEFI box. Try disabling secure-boot in your BIOS. It will probably boot the newer kernel that way.

I just came back to post that I tried exactly that … First I tried disabling secure boot support in YaST’s bootloader options, but this caused grub to spit the dummy and boot straight into Windows. So I disabled secure boot in BIOS, and was able to boot the new kernel. I got the “touchpad not found” message AGAIN, but despite this the touchpad is now functioning quite nicely!!

If I now go and re-check the secureboot support box in YaST (but leave it disabled in BIOS) will that break the system?

From what I have read, secureboot requires a Microsoft-signed key in order to function with other OSes. The factory-supplied kernel obviously had one while the newest kernel obviously does not. At some time in the future will a signed 3.15.* kernel be made available, or is there some way to attach a signature to the currently-installed kernel?

Thanks all for your help. This has been a learning experience; frustrating but not unenjoyable :slight_smile:

Try setting up Yast -Grub2-EFI with secure boot. During the reboot enable secure boot in UEFI and see if that enables the whole boot process.
I have been using Linux since 2000 with Mandrake 7. Comparing Linux in 2000 and now is like night and day;) Hardware GUI support/configuration has come a long way.
And, I’ve learned so much about my hardware and how the Linux kernel & OS controls the performance. A lot was also been discovered from my own errors, bug testing and reporting.
Something I would have never have learned under Windows.

As far as the resume problem is concerned, I would log on to Bugzilla, report your problem as a bug and ask about the signature for kernel 3.15.6x.
That is if the problem still exists after changing the Yast Boot Loader settings.

Please read through the blog articles about the tools users can use to sign and manage their own key database for their own kernel(s).
For openSUSE 13.1:**

Follow Up

To find if the kernel is signed. Type:

# rpm -qi kernel-desktop