Touchpad not working after login

Recently updated Opensuse 13.1 for important updates + security updates and touchpad isnt working after entering password.

I have Acer Aspire 4736

Which desktop?

When I last tried it with Gnome, I can use the keyboard Fn keys to enable or disable the touchpad. And it remembers that for the next time I login. But I can still toggle it again with the Fn keys.

That doesn’t happen in KDE – or at least it does not happen for me.

I’m mostly pointing out that different desktops behave differently. So you should provide the information on which desktop you are using.

Sorry I wasn’t able to mention that… Im using OpenSUSE 13.1 KDE 64 bit…

it is initially working on login screen but after logging in I cant access it.

I was also using an external keyboard with touchpad (Logitech K400r) while updating. Would that have anything to do with it?
External keyboard+touchpad works fine but the built in touchpad just stops after login.

That happens to me, too. But, in my case, that is because “synaptiks” is one of the processes automatically started on login, and I have it configured to disable the touchpad if there is a usb mouse plugged in.

Check what software is running.

The default for KDE is to save your session on exit, and restore on startup. It you ever ran something that disabled the touchpad, that is probably being restarted for each session.

Yep, touchpads are both working now… Thanks for the advice

The problem has come back… after update

I tried to close every program i know that i opened then restarted but touchpad does not work like before…

Additional observations:

touchpad randomly disables itself while using laptop

touchpad works while i input login password then stops 2-3 seconds after the disk icon is displayed

previously i could enable the randomly disabled touchpad with the button near the touchpad but now it does not reenable it

Have found a temporary solution from another forum:

Touchpad now working :smiley:

I followed the steps below and restarted.


To my knowledge, the key - if it behaves as all others keys do - should toggle the touchpad on/off. Unfortunately some hardware behaves a little differently (the touchpad device may have disappeared entirely - or the key may be generating another key event now for instance).

If you logout, does the touchpad work at the login screen? If it does not, then it is quite likely your touchpad has been disabled at the hardware level - in which case a reboot may help.

If it does work at the login screen, then try disabling the “Touchpad Enabler” service in System Settings > Startup & Shutdown > Service Manager.