Touchpad is disabled for a few secnds when a button on the keyboard is pressed.

Whenever I type anything on the keyboard, the touchpad is disabled. Is there a fix?

There’s probably a setting for that.

In KDE, it is Configure Desktop (personal settings) → Input Devices → Touchpad

That’s for 11.4 with KDE 4.6. I think the names have changed since 11.3. I recall seeing a similar setting in gnome, but I don’t remember the details.

I tried that but couldn’t find the option I was looking for. I don’t think its my touchpad as it worked fine in mandriva.

It must have something to do with the synaptiks daemon as when I stopped it running at startup it fixed my problem

I went back into the settings and found the right option. Can’t believe I missed it.

I’m glad you found it.

Some folk (I’m one of them) find it very distracting when we accidentally touch the touchpad while typing, and the cursor wanders all over the place. So we find that a useful option.

I use “mouse follows cursor” and if the cursor moves too far, the window I thought I was typing into will lose focus.

I can see why its useful. If the default time wasn’t as long I might have kept it, but I though it would be easier to switch it off that adjust the time to suit me.

Wish I had your problem.

You can just do the opposite of what was mentioned above in the
synaptiks config …

Hello, the daemon is calle syndaemon and it has several options, but couldnt find it practical since you cant set it less than (I think) 1 second of pause.

I found that its better (for me) to reconfigure the touchpad area, i.e. I have a DV7 notebook and the touchpad is reaaaaaaly big, so when typing I accidentally tap it lossing focus.

This is the config file to shrink the touchpad area (for my touchpad, others may be slight different…)

[email]sebadamus@itsalive:/etc/X11/xorg.conf[/email].d> cat 50-synaptics.conf
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option  "HorizScrollDelta"      "0"
        Option  "AreaLeftEdge"          "1600"
        Option  "AreaRightEdge"         "5400" 
        Option  "AreaTopEdge"           "1600"
        Option  "AreaBottomEdge"        "0"
        Option  "FingerLow"             "20"
        Option  "FingerHigh"            "40"