touchpad - how to turn off while typing

I have a toshiba satellite, it has a ALPS touchpad. I would like to turn off the sensitivity when I am typing so that my big hands dont bump it and mess up my typing stream.

I have tried access to the control panel as well as YAST. Nothing seems to have a control for turning off the touchpad during typing.

Anyone know how to resolve this.

Here is some information:

59: PS/2 00.0: 10500 PS/2 Mouse
[Created at input.183]
UDI: /org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port_logicaldev_input_0
Unique ID: AH6Q.5+smWHVjPI3
Hardware Class: mouse
Model: “AlpsPS/2 ALPS GlidePoint”
Vendor: 0x0002
Device: 0x0008 “AlpsPS/2 ALPS GlidePoint”
Compatible to: int 0x0210 0x0003
Device File: /dev/input/mice (/dev/input/mouse1)
Device Files: /dev/input/mice, /dev/input/mouse1, /dev/input/event3, /dev/input/by-path/platform-i8042-serio-4-event-mouse, /dev/input/by-path/platform-i8042-serio-4-mouse
Device Number: char 13:63 (char 13:33)
Driver Info #0:
Buttons: 3
Wheels: 0
XFree86 Protocol: explorerps/2
GPM Protocol: exps2
Config Status: cfg=no, avail=yes, need=no, active=unknown

If you are running KDE, try this:

Disable - Enable Touchpad

I have used it for a couple of years. Extract the file first. Then right click on it and select “Disable Touchpad”. It resets after each reboot, but otherwise works quite well.

ok, thanks.
i ran the command and it works perfect.

i will download, cause its my wife that uses this machine and she dont get it.

actually, i would prefer to default with the pad off. anyone know how i can set it up to default off? and use this utility to turn it on if necessary?

please advise,

There is the tool called syndaemon which should disable touchpad while typing,
though I didn’t try it myself (I don’t have touchpad).

man syndaemon
Syndaemon - openSUSE Forums
HowTo: Disable Synaptics Touchpad While Typing - Ubuntu Forums
and google of course.

To disable it at startup you can add the command

synclient TouchpadOff=1

as root to the end of the text file /etc/init.d/boot.local

The command will then run at each boot. Be sure to have a way to activate it back with the keyboard (a shortcut to synclient TouchpadOff=0, for example) in case you don’t have a mouse handy.

yes, i want to set up a shortcut. how do I assign a keyboard shortcut with a command?

  • bmccall17,

silly question maybe, but did you try Fn+F9? That worked fine back then with my Toshiba.


wow. that is one silly question!! It worked by the way.
i guess i assumed that the keyboard functions would need special drivers and such.

thank you for being a great community of suppot!!!

this works perfect in the boot.local. thank you!!!