Touchpad gone hay-wire - openSUSE 11.0 - Dell XPS M170

Fellow openSUSE users,

Heres my current setup
I have a Dell XPS M170 Laptop
running openSUSE 11.0 w/ KDE 4.0
and ran auto-config in the setup process.

Heres the problem
My touchpad mouse on my laptop seems be completely FUBAR! Sometimes it responds when I move it, sometimes it doesn’t. Other times is so sensitive that when I click on the programs list I can’t even navigate because it won’t even let me get up to the programs due to the fact when I try to move it up there, it takes it as I’m clicking on the programs menu again and collapses it. Also when I try to Shutdown, I click on the icon in the bottom right hand corner, then try to navigate to the middle of the screen and it takes it as another click before I can get to Shutdown, Restart, or anything else and then the Shutdown options go away. Please offer a config that might work with my laptop and current configuration… or which mouse driver I should select from the hardware options. It really makes the whole OS un-usable in its current state. I appreciate any assistance… Thanks so much.

From Iraq,

P.S. I can’t download openSUSE 11.1 due to the sucky’ness of the bandwidth out here, it always stalls after about 2gigs or so ;-( Please support your troops! :stuck_out_tongue_winking_eye:

As I have no real KDE 4.0 knowledge… I can’t help you there.

One thing that is advisable is to at least install KDE 3.5.9 alongside KDE 4.0 (as 4.0 is a preview/development release) to rule out your troubles are not from KDE 4.0. Shouldn’t take too much bandwidth (not like the DVD anyway) and can be added by using Software Management and selecting PATTERNS > KDE 3 desktop
Also mentioning this because I’ve seen similar setups (laptop hardware) without these issues reported.

Have a wait to see what others have as tips as there are many here adventuring the KDE 4 lands…

Wishing you luck,

ps. have a look here : Laptop Touchpad Responsivness Issue - openSUSE Forums

If your pointing device configuration shows extras, once you remove them, you should be able to configure your touchpad via the KDE4 Control Panel’s mouse/pointer configuration. Set the sensitivity, acceleration, etc. until you get something you’re comfortable with.

In yast->mouse configuration, Try to deactivate the pointer in mouse 2. It works on my vaio:)