Touchpad disabled because a mouse is plugged in (when not really)

Hi,
I’ve got this XPS15 9560 laptop whose touchpad is not working as it is not responding to any input.
So far, at least I realize that the laptop says it always detects a plugged in mouse even when nothing is plugged in except the power cable. At reboot, a notification would say “touchpad is disabled because a mouse is plugged in” at reboot with or without a mouse connected.
The following is the screenshot of the touchpad setting page:

cat /proc/bus/input/devices
I: Bus=0018 Vendor=06cb Product=7a13 Version=0100
N: Name="DLL07BE:01 06CB:7A13 Touchpad"
P: Phys=i2c-DLL07BE:01
S: Sysfs=/devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-8/i2c-DLL07BE:01/0018:06CB:7A13.0004/input/input33
U: Uniq=
H: Handlers=mouse3 event20
B: PROP=5
B: EV=1b
B: KEY=e520 10000 0 0 0 0
B: ABS=2e0800000000003
B: MSC=20

There’s a dmesg that says

[1.816739] psmouse serio1: synaptics: Your touchpad (PNP: DLL07be PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want to try setting psmouse.synaptics_intertouch to 1 and report this to linux-input@vger.kernel.org.

I tried adding psmouse.synaptics_intertouch=1 at kernel option using the yast2-boot loader but still no go.

There’s probably something that tells your desktop software that a mouse is plugged in. I use a wireless mouse, and as long as the wireless dongle is plugged it, it will disable the touchpad – even if the mouse no longer exists.

I see that the setting doesn’t show up for you. That’s a known bug (KDE bug 415364). You can remove that setting by manually editing
~/.config/touchpadrc

2 Likes

Hi, many thanks for the answer. At least I can use touchpad now after manually editing touchpadrc to disable the auto-disable feature.
What still puzzles me is: what mouse is it detecting when everything is unplugged from the ports of the laptop?
I do use a wireless logitech mouse with a dongle, but the dongle has already been removed when the touchpad is disabled.
Here’s how I reproduce the problem:

  1. Shutdown laptop.
  2. Unplug everything
  3. Boot up, and a notification would come up saying “touchpad is disabled because a mouse is plugged in”.
    Any clue on how to solve this?

It’s a bit hard to guess.

I’m glad you were able to get around the problem by editing that file.