Touchpad cursor frozen during installation of Leap 15.1

I have a Lenovo L340 laptop. I tried to install Leap 15.1 with a DVD. The cursor froze in the middle of the page. This was not a problem until I got to the section where window managers are chosen because until then I could use the arrow key to make selections. The cursor works fine on the Windows10 side of the computer. Is there a way of working around the frozen cursor? I looked on the support database and I did not see anything similar to this.

I had a similar problem (not in a Lenovo) and found a setting in the Boot Menu which allowed you to swap between two different touchpad settings. Swapping them over solved the problem.

  1. Connect USB mouse or other pointing device.

or

  1. Use Tab and arrow keys.

My bios does not have this option nor does the installation program, but thanks for responding.

I tried using Tab and arrow keys but this did not work. I may buy a mouse which would be a good thing to have anyway. Thanks for responding.

I bought a USB mouse and this worked so I got Leap 15.1 installed. The touchpad still does not work as yet but the mouse does.

It’s likely (albeit speculation on my part) that a newer kernel will be required to provide the support for this device.

These commands may elicit more info about your touchpad device…

sudo libinput list-devices
sudo dmesg|grep input

If you want to try a newer kernel

sudo zypper ar -f http://download.opensuse.org/repositories/Kernel:/stable/standard kernel:stable
sudo zypper dup -r kernel:stable

Reboot once the new kernel has been installed and see if that helps with the touchpad detection. You can always boot using the older kernel if you have problems (via the advanced options grub menu). You also need to be aware if using proprietary graphics drivers since they would need to be rebuilt for the newer kernel.

:)The problem is solved. I downloaded a touchpad rpm from en.opensuse.org and then restarted.

It’s good that this problem is now resolved, but it would be nice if you could clarify with a little more detail about which touchpad package you were missing.

I suspect that this is an instance of 1155982 – Upgrade to 4.12.14-lp151.28.25-default breaks builtin pointing devices which has been reported for several Lenovo devices.

If the installation was attempted with an internet connection, the faulty kernel-default-4.12.14-lp151.28.25.1 may have been installed from the Leap-15.1-update-oss repository. This could have been avoided by not using on-line updates during the install, then updating (YaST or zypper) avoiding that kernel. I stayed with kernel-default-4.12.14-lp151.28.20.1 for my Lenovo Yoga 3 Pro (1370).

There has been a more recent update with kernel-default-4.12.14-lp151.28.32.1 which should enable installation.

However this seems unstable on my machine (input failed twice following sleep) and I have reverted to the previous good kernel so as to get some work done. The instability remains anecdotal as I have not tested rigorously or seen other reports.

Yes, I’m aware of that regression…there were some other similar recent threads I participated in. My last post was more directed at the OP’s comment that they downloaded a touchpad driver, and all was now good. Not sure what they were really referring to here.