Touch-Pad Pointing Arrow Immovable for Periods of Time While Using a WiFi Card in openSUSE 11.3

Hello. I have had recent problems in the Lightweight X Windows System, version 11 (X11), Desktop Environment (LXDE) in openSUSE 11.3 while using a WiFi card in my notebook computer to receive WiFi Internet signals broadcast within a public library. The problem is that the touch-pad arrow sometimes became immovable. And some other computer and/or WiFi activities appeared to cease, too, for a period of time. After waiting awhile, the touch-pad arrow could sometimes be moved again; but sometimes I restarted my computer to leave that situation. One of such freezes occurred when I clicked on the Network Manager panel icon and selected something like “Create 802.11… wireless…” Another such freeze occurred during a download or installation of an update from the Internet. When not using the WiFi card, for example when opening a file saved on the computer’s hard-disk drive or using an ethernet card to connect to the Internet, generally the touch-pad arrow did not become immovable for a period of time.

Computer: Hewlett Packard, ZE1110, Pavilion notebook computer
WiFi PCMCIA (Personal Computer Memory Card International Association) cardbus card: LevelOne N_One WPC-0600, which I can plug into the left side of my computer
Operating system: openSUSE 11.3, periodically updated with updates obtained from the Internet
Linux kernel version: 2.6.34.7-0.5.1.i586
The openSUSE-11.3 Linux operating system currently uses “AR5008 Wireless Network Adapter (wlan0)” for the physical WiFi card.
The WiFi signal strength has been variable with at least time from 58 to 78 percent in openSUSE 11.3 and measured when the pointing-arrow freezes did not occur.

A look at the recent history might provide one or more additional clues to some people as to what caused the problem and/or how to eliminate it.

11/06/10: I updated the Linux kernel to version 2.6.34.7-0.5.1.i586. Its installation was recorded in /var/log/zypp/history as being “ok.”

11/15/10: My WiFi card arrived and worked okay without any pointer-arrow freezes in openSUSE 11.3 with the WiFi broadcasting in a public library. Some updates to software in my openSUSE-11.3 installation were obtained from the Internet and installed onto my computer’s hard-disk drive.

11/17/10: I increased the physical Random Access Memory (RAM) from 256 MegaBytes (MB) to 1,024 MB by replacing a pair of RAM modules with ones having larger data-storage capacities. But those replacing RAM modules were clearly incompatible with my computer. One of the early symptoms of a problem was the message “Xfce power manager HAL daemon is not running.” In later “reboots” of my computer the Dolphin file manager was invisible; I had a black screen above the panel; and even the green color of the openSUSE-11.3, login screen was missing. The problems appeared to increase with time. The openSUSE-11.3-Linux-containing partition /dev/sda7 was reported to contain file system errors. A check of it was forced.

11/18/10: I returned to the original, working pair of RAM modules totaling 256 MB in data-storage capacity. All of the above problems reported for 11/17/10 gratefully disappeared.

11/26/10: A backup image of my hard-disk drive was made.

12/6/10: The installed pair of 128-MB RAM modules was replaced by a pair of Samsung Corporation, 512-MB RAM modules denoted by PC133S-333-542, M464S6453EV0-L7A, and containing integrated circuits labeled with K4S560832E-VL75, Samsung, and 622. They gratefully worked well in my computer and passed six tests.

12/15/10 and perhaps 12/14/10: Some openSUSE-11.3 updates were obtained from the Internet using my WiFi card at the library and installed onto my computer’s hard-disk drive.

12/17/10: I returned to using the pair of 128-MB RAM modules in my computer and restored my computer’s hard-disk drive back to its state on 11/26/10. Then I transferred from a disc to my hard-disk drive some personal files saved before that restoration was made. Some time after that restoration the pair of 512-MB RAM modules were returned in place of the 128-MB RAM modules in my computer.

12/20/10: The “freezes” of my touch-pad arrow and some other computer activities in openSUSE 11.3 while using my WiFi card in my computer at the library were first observed. Nevertheless when such freezes were not occurring, updates to openSUSE 11.3 were downloaded from the Internet and installed onto my computer.

12/30/10: The “freezes” of my touch-pad arrow and some other computer activities in openSUSE 11.3 while using my WiFi card in my computer at the library were again observed. Nevertheless when such freezes were not occurring, updates to openSUSE 11.3 were downloaded from the Internet and installed onto my computer. I think I am here probably missing the reporting of some more days which included such freezes and/or updates of openSUSE-11.3 software.

12/31/10: Using my openSUSE-11.3 installation Digital Video Disc’s (DVD’s) “Rescue system” option the commands “fsck.ext4 -n /dev/sda7” and “fsck.ext3 -n /dev/sda8” were entered for the openSUSE-11.3-containing partition sda7 and the /home-containing partition sda8. In each case the reported result was “clean.” Earlier file-system errors were reported after inputting the first of these two commands on a mounted, /dev/sda7 partition; I presume those reported errors were due to trying to run fsck.ext4 on a mounted partition, something for which fsck.ext4 may not be designed; therefore I assume that there are no file-system errors on the openSUSE-11.3-containing partition /dev/sda7 or the /home-containing partition /dev/sda8.

Other people have in the past on the Internet reported suspicions of WiFi driver problems and particularly the Linux-kernel ath9k driver I am also using with my WiFi card, for example for type-n, as in 802.11n-capable, WiFi cards. Others’ reported symptoms were disconnections from the Internet and reported low, WiFi signal strengths when using version 2.6.30… of the Linux kernel and/or the ath9k driver. A solution for some of those people I think was to “fall back” to using version 2.6.29 or earlier of the Linux kernel. However, I have been using the same Linux kernel version of 2.6.34.7-0.5.1.i586 both before and after the occasional pointer-arrow-freezes I report here.–So assuming that the ath9k driver in my case only came built into this version of the Linux kernel and could not be updated apart from the Linux kernel, this makes it hard to explain the pointer-arrow freezes I have observed as due to a change in the ath9k, WiFi card driver as distributed from an openSUSE Web site.–In fact openSUSE 11.3 reports ath9k as “Kernel driver: ath9k.” A possibility I am considering is that some openSUSE-11.3 update obtained and installed on 12/15/10 that became publicly available between 11/15/10 and 12/15/10 might have caused the pointer-arrow freezes I observed in my next trip to the library on 12/20/10 when I used my WiFi card there in my computer. However, my insertion (and removal) of the incompatible RAM into my computer also occurred during that time interval, making that another imaginable possibility of the cause of the pointer-arrow freezing. In my written records over the period 11/15/10-12/31/10 when I had good WiFi connections to the Internet, the reported WiFi signal strengths did not appear to be very different before and after the pointer-arrow freezes began to take place. However, when there was a pointer-arrow freeze, I might not have been able to read the detected, WiFi signal strength.–So I suppose a hypothetical decrease to somewhere below 58 percent in the detected WiFi signal strength by my computer and WiFi card could still be an imaginable possible explanation for the pointer-arrow freezes; but if so, such decreases would had to have been more frequent in later days than on 11/15/10, something I doubt. Have others among you observed pointer-arrow freezes when the detected, WiFi signal strength decreased to too low a level? Or was the symptom of such a decrease simply that data could no longer be downloaded from or uploaded to the Internet, while the pointer arrow continued to be movable? If so, this may point to a software problem in my openSUSE-11.3 installation.

One other thing to mention is that my WiFi card became warm with use inside the small volume of my notebook computer. When my WiFi card was used in a computer loaded with a Windows XP Home Edition operating system, there were no touch-pad, pointer-arrow freezes; so my WiFi card itself appears to be acceptable. In a simple-minded way of thinking this ought to delimit the problem to a software problem in my openSUSE-11.3 installation or one of WiFi signal strengths being occasionally too weak to be handled by my openSUSE-11.3 software. And between these two choices, the software problem within my installation of openSUSE 11.3 seems more likely to me. Suppose the RAM modules incompatible with my computer and installed in it for one to two days could have somehow corrupted my installation of the Linux kernel. Is the corruption of a Linux kernel possible? And if so, would such hypothetical corruption of the Linux kernel have escaped detection by the program fsck.ext4? If so, how does one test the validity of his installation of the Linux kernel? If the Linux kernel is corrupt, would reinstalling it be a possible solution to the pointer-arrow occasionally freezing? And apart from reinstalling openSUSE 11.3, how could one replace the Linux kernel with an uncorrupted Linux kernel of the same version number? What are some of your ideas to explain and/or eliminate these pointer-arrow freezes?

I kept the pair of working, Samsung Corporation, 512-MegaByte (MB), Random Access Memory (RAM) modules in my computer. By right-touch-pad-button-clicking on the Network Manager panel icon, selecting “Edit Connections,” on the “Wireless” tab clicking on the “Auto library” connection on my computer, then finally clicking on the “Delete” button, I deleted that “Auto library” interface previously set up for use in a public library. The plan was to start with a freshly made interface in Network Manager.

Then I went to a local business which has WiFi broadcasting. With my WiFi card in my portable notebook computer I started openSUSE-11.3 Linux and connected to the Internet there by clicking on the Network Manager panel icon and eventually selecting the name of that business associated with the WiFi broadcasting there, as detected by my WiFi card (In between those two steps I might have clicked on “Wireless networks…”). The software for that newly made interface was again called wlan0 and should in that way I hope have been freshly made. The detected WiFi signal strength varied with time from 54 to I think around 64 percent. During around 20 minutes of use there was one noticeable period of time when the touch-pad pointing arrow was immovable; it occurred during a download of items to a Web page. After a short period of time of seconds or perhaps a few tens of seconds the touch-pad pointing arrow was again movable.

So the “frozen”-arrow problem was not confined to one particular WiFi-broadcasting location or software interface automatically built within openSUSE 11.3 for that particular location and the same WiFi card. If the software in the library interface were perhaps somehow corrupted by for one to two days using incompatible Random Access Memory (RAM) in my computer, the hope was that having openSUSE 11.3 automatically build a fresh, WiFi, software interface and perhaps freshly detecting my WiFi card might have eliminated the “sometimes-frozen” pointing-arrow problem; but unfortunately that problem was not eliminated in that way.

That could be the longest message I have ever read that says you have problems with your mouse/touchpad freezing from time to time. Your message was very detailed and well written in a chronicled manner. When I looked up this computer, it said it was a 1 Ghz AMD Duron CPU with a 20 GB hard drive. When you start talking about Logical Partitions 7 and 8 it makes me wonder how you are doing with disk space? I request a read out of several items using terminal commands:

cat /etc/fstab
free
su -
password:
fdisk -l

Copy and past the results of these commands here for us to see. It might be nice to wait till you are having some problems to output this text, but not required. Consider that if you run low on memory, you start using the swap partition, so this slows you down. If you further run low in disk space, it can make it worse. It is one thing when a hardware item does not work and another when it works, but freezes ever so often. I am thinking your CPU is under a heavy demand due to low memory and or low free disk space and during high disk activity, your touchpad freezes, returning when activity slows down again. It is just a thought. Also, consider that software continues to move forward requiring ever more memory and disk space even as this laptop stopped a long time ago.

By the way, the fact that you have everything working, including Wireless, tells me you are doing fine with Linux and may just be running low on resources. Also, in the future, less detail would be OK. I have created large messages before myself and so I am very aware of the effort required to write this. However, you may scare off some people that might help due to the massive detail you gave.

Thank You,

James, I think you have some really good thinking here. Thanks to you my problem gratefully appears to have been solved. That is when using my WiFi cardbus card in a McDonald’s Restaurant to receive WiFi Internet broadcasting in 32 minutes of use in the Lightweight X Windows System, version 11 (X11) Desktop Environment (LXDE) and 14 minutes in the K Desktop Environment (KDE) I did not notice any instances of an immovable pointer arrow for several seconds or longer in openSUSE 11.3. Below I explain what was done that preceded these successes for which I am grateful.

By “booting” my computer using the free, live, Compact Disc- (CD-) based, .iso program Gnome Partition Editor (GParted) 0.7.1-1, which “recognizes” ext4 and some other types of file systems, I increased the size of my Linux swap partition /dev/sda9 from 1.01 binary GigaBytes (GiB), where 1 GiB equals 1.07374 GigaBytes (GB), to 1.91 GiB, or about 2.05 GB, which is about twice the 1.024 GB of physical Random Access Memory (RAM) installed in my computer. And I increased the size of my openSUSE-11.3-Linux-containing partition /dev/sda7 from 8.04 GiB, of which 7.24 GiB were occupied with data, to 10.29 GiB; that increased the free space on that partition from 821.11 binary MegaBytes (MiB), or 782.93 MegaBytes (MB), to 3.06 GiB.

In the LXDE I did have one instance of a “crash” of openSUSE 11.3 while playing four single-Web-page- and one media-player-based, .mp3 (Moving Picture Experts Group [MPEG] Audio Layer III] audio files all at the same time. But I don’t take that crash seriously.–I can at least imagine that my computer could sometimes have a hard time with such an unusual situation of playing five .mp3 files at once, one I expect few people would want. But I did want to see how my computer would perform with a load on it. The test in the KDE was a good one because I read that KDE 4.0 required 800 MB of RAM, compared to my computer’s 1,024 MB of physical RAM; and I think the LXDE of the openSUSE-11.3, Linux operating system probably includes some version of KDE 4. Two activities in which past pointer-arrow “freezes” in the LXDE did occur, namely clicking on Network Manager’s “Create …802.11…” and viewing a certain Web page, gratefully did not cause pointer-arrow freezes after the increases in the sizes of the partitions /dev/sda7 and /dev/sda9.

Here are some partial responses from my computer to the commands you requested I input and post my computer’s responses which were obtained prior to increasing the sizes of the partitions /dev/sda7 and /dev/sda9:

linux-iy6k:~ # cat /etc/fstab
/dev/disk/by-id/ata-ST9160821A_5MACWNDR-part9 swap swap defaults 0 0
/dev/disk/by-id/ata-ST9160821A_5MACWNDR-part7 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-ST9160821A_5MACWNDR-part8 /home ext3 defaults 1 2
…and some more lines that relate to other partitions.
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

Part7 is my openSUSE-11.3-Linux-containing partition; part8 contains my openSUSE-11.3 /home directory; part9 is my Linux swap partition for openSUSE 11.3. ST9160821A is the model of my five-year-warrantied, Seagate hard-disk drive for use with an Ultra ATA/100 (Advanced Technology Attachment, 100-MB/s external transfer rate) hard-drive bus; it can also be referred to as a Parallel ATA (PATA) hard-drive bus or hard-disk drive, or as using an ATA-6 interface.

linux-iy6k:~ # free
total used free shared buffers cached
Mem: 1015008 657280 357728 0 39576 491608
-/+ buffers/cache: 126096 888912
Swap: 1060252 0 1060252
I guess that part of this might mean that 357,728 bytes among 1,015,008 bytes of RAM were “free,” based on the closeness of the labeled “total” of 1,015,008 to the 1,024,000 bytes of physical RAM installed in my computer and with 0 probably bytes of the swap partition (/dev/sda9) being used. But this may hint that there could be problems with already 66 percent of the RAM being used probably in the LXDE and probably with not much other computer activity at the time while typing the above terminal commands.

linux-iy6k:~ # fdisk -l (That’s the letter “l” at left, instead of the similar-looking digital equivalent of “one.”)

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x04e104e0

Device Boot Start End Blocks Id System
…(Lines for two other partitions)…

/dev/sda3 * 8854 16773 63617400 5 Extended
…(Line for two other partitions /dev/sda5 and /dev/sda6)…

/dev/sda7 15077 16125 8426061 83 Linux
/dev/sda8 16126 16641 4144738+ 83 Linux
/dev/sda9 16642 16773 1060258+ 82 Linux swap / Solaris

The extended partition /dev/sda3 contains the partitions /dev/sda5 through /dev/sda9. Although my hard-disk drive has a capacity of 160 GB and I think is 48-bit Logical-Block-Addressing (LBA), I think my computer’s current Insyde Software JA.M1.31 Basic Input Output System (BIOS) might limit my hard-disk drive’s usable portion to [2**(28) -1] sectors X 512 bytes/sector = 137.4 GB, probably as a 28-bit-LBA-compatible BIOS. So far I haven’t found a 48-bit-LBA-compatible BIOS for my Hewlett Packard, ZE1110, Pavilion notebook computer that I could obtain free of charge. Please provide a source for one, if any of you knows of a 48-bit-LBA-compatible BIOS for a Hewlett Packard, ZE1110 or ZE1115, Pavilion notebook computer with a chip set having technology code JA and a VIA KN133 northbridge circuit and a VT8231 southbridge circuit. I think a 48-bit-LBA-compatible BIOS should support the use of [2**(48) - 1] sectors X 512 bytes/sector = 1.44 X 10**(17) bytes or up to 144 petabytes on a hard-disk drive. Such a BIOS would allow me to use the presently perhaps unusable (160.0-137.4) GB = 22.6 GB of my present hard-disk drive. But this is at present not a serious problem because right now I have plenty of free space on my hard-disk-drive. Yes, James, my computer, purchased on I think February 23, 2002 did originally have a 20-GB hard-disk drive in it. It failed in about August of the year 2003 and was replaced by I think a 40-GB hard-disk drive. Then on January 15, 2009 that 40-GB hard-disk drive was in turn replaced by my present, five-year-warrantied, 160-GB, Seagate, hard-disk drive.

With the help of the above table and [SOLVED] what all means in fdisk -l](http://www.linuxquestions.org/questions/linux-newbie-8/what-all-means-in-fdisk-l-765730/) and http://en.wikipedia.org/wiki/Cylinder-head-sector/ on the Internet, I could only partly understand what the numbers in the above output of “fdisk -l” meant for my computer’s hard-disk drive. From the above table the unit of “Start” and “End” is the cylinder containing 16,065 sectors times 512 bytes/sector or 8.225280 MB. Then from [SOLVED] what all means in fdisk -l](http://www.linuxquestions.org/questions/linux-newbie-8/what-all-means-in-fdisk-l-765730/) I learned that 63 sectors times 512 bytes/sector=0.032256 MB are apparently not available for the computer user’s use and that the block size used in response to the command “fdisk -l” is 1,024 bytes/block. So with these things in mind I compute the number of blocks available for my use on the partition /dev/sda7 of my hard-disk drive as:

(16,125 - 15,076) cylinders X 8.225280 MB/cylinder - 0.032256 MB ] / 1,024x10**(-6) MB/block ] = 8.426061 megablocks = 8,426,061 blocks, which agrees with the number under “Blocks” in the above table.
That number of blocks at 1,024 bytes/block corresponds to 8,628,286,464 bytes, or 8.628286464 GB = 8.03573 GiB, which agrees the total size of 8.04 GiB of the partition /dev/sda7, considering both used and unused blocks on that partition, as determined by the use of the program GParted 0.7.1-1. So evidently the above table tells us the sizes of some partitions, but not the number of free or vacant blocks or vacant megabytes on them.

(continued in the next reply)

(continued from the previous reply)

To obtain the numbers of free bytes on the partitions /dev/sda7 and /dev/sda8 with the help of a kind neighbor’s fast Internet service I first downloaded the latest stable release of the Gnome Partition Editor (GParted), which was version 0.7.1-1 of it released on December 15, 2010. It supported the ext4 file system used on the partition /dev/sda7 for my installation of openSUSE 11.3. Gratefully during the download of the .iso file for GParted 0.7.1-1 from GParted - Browse /gparted-live-stable/0.7.1-1 at SourceForge.net on the Internet in my installation of the openSUSE-11.3, Linux operating system there was no pointer-arrow freeze that I noticed while using my portable notebook computer and WiFi cardbus card in my neighbor’s home with my neighbor’s WiFi broadcasting. Then I returned to where I live and “burned” (wrote) that .iso file directly onto a Recordable Compact Disc (CD-R) using my BUSlink, model UII-RW52E, external CD writer and the same portable notebook computer. I could then “boot” my portable notebook computer from that so-called “live” CD; I think that CD-R may then have contained its own operating system and a program which could determine and display the statuses of the partitions on my hard-disk drive. Oh! Actually I used two versions of GParted: 1) the older GParted 0.3.9-13, which did not support the ext4 file system and mistakenly labeled it as ext3, to obtain the statuses of my hard-disk-drive partitions before resizing and/or moving some of them, and 2) GParted 0.7.1-1 for resizing and/or moving some partitions and afterward reporting the used and unused sizes of the partitions of my hard-disk drive. The portion of data in Table 1 below was obtained using the older GParted 0.3.9-13 before the resizing and moving of some partitions were performed:

Table 1. Output of the Gnome Partition Editor (GParted) 0.3.9-13 before resizing and moving some partitions of my computer’s hard-disk drive

Partition…Filesystem…Label…Size…Used…Unused…Flags


/dev/sda3…extended…60.67 GiB…----…----…boot


/dev/sda7…ext3…8.04 GiB…7.23 GiB…821.11 MiB
…(but really was ext4)

/dev/sda8…ext3…/home…3.95 GiB…360.86 MiB…3.60 GiB
/dev/sda9…linux-swap…SWAP-sda9…1.01 GiB…----…----
unallocated…unallocated…20.56 GiB…----…---- ______________________________________________________________________

The extended partition /dev/sda3 contained the higher-numbered partitions sda5, sda6, sda7, sda8, and sda9, some data for a few of which are tabulated above (For some reason the partition /dev/sda4 either did not exist or was not tabulated by GParted.). I noticed that the free or “Unused” portion of the partition /dev/sda7 was a small percentage of the size of the partition /dev/sda7, which contained the openSUSE-11.3, Linux operating system. I decided to not only increase that partition’s size, but also to almost double size of the Linux swap partition to make it double the size of the installed RAM in my computer.
To do that I used GParted 0.7.1-1 to resize and move some partitions and thereby obtained the following results for those partitions tabulated in Table 2:

Table 2. Output of the Gnome Partition Editor (GParted) 0.7.1-1 after using it to resize and move some partitions of my computer’s hard-disk drive

Partition…Filesystem…Label…Size…Used…Unused…Flags


/dev/sda3…extended…60.67 GiB…----…----…boot


/dev/sda7…ext4…10.29 GiB…7.24 GiB…3.06 GiB
/dev/sda8…ext3…/home…3.95 GiB…477.50 MiB…3.49 GiB
/dev/sda9…linux-swap…SWAP-sda9.1.91 GiB…----…----
unallocated…unallocated…20.56 GiB…----…----


Notice that with GParted 0.7.1-1 the file system for /dev/sda7 was properly listed as ext4. Basically I used GParted 0.7.1-1 to shrink a partition within the extended partition /dev/sda3 that I did not list in the above Table 2 and which contained lots of vacant blocks in order to increase the sizes of the partitions /dev/sda7 and /dev/sda9. A minor point is that apparently due to some disk activity of mine I see from Tables 1 and 2 that I had some increases in the numbers of binary bytes used in the partitions /dev/sda7 and /dev/sda8 between the uses of versions 0.3.9-13 and 0.7.1-1 of GParted. The program GParted has been a tremendous free program! After version 0.7.1-1 of GParted probably completed the resizing, moving, and copying of the used blocks to their new locations on /dev/sda7 containing the openSUSE-11.3 operating system, that program even reported checking for file system errors and, if possible, “fixing” them with the fixing I suppose only when necessary!

So thanks very much for your help, James! First of all, thanks for being diligent enough to read my posting. That was good! Secondly your experience is valuable (I noticed that you had many posts in openSUSE forums!); so based on your experience and knowledge, there was something probably correct in your sense of what could have been wrong in my case. I gather that you thought the primary cause of the pointer-arrow freezing for periods of time may have been too small a swap partition; then after that you thought possibly too little free space on the openSUS-11.3-Linux-containing partition could have been a contributing cause to the pointer-arrow freezing. And lastly you kindly took the time to post your thoughts for me. The world needs diligent, knowledgeable, and kind guys like you who are kindly willing to share their knowledge, including from their experiences, in order to help other people like me! Thanks for excelling in at least these three categories of life at least for my benefit! So in gratitude I write, “Thanks, James!” and express some love here from me to you!

Oh yes, my pointer-freezing problem gratefully appears to have been solved; and in addition if you can answer some of the questions near the end of my initial posting in this thread and answer them here, thank you in advance for doing so. In that way I could learn some more things.

Hello 2009Newbie and good morning to you from Austin.

I must say that you like to write very detailed messages that leave little to the imagination. So, the short version of what you said is, you increased the size of your swap file, using GParted and the mouse pointer freezing seemed to have gone away. That is good news.

As to your question on your BIOS, most often BIOS updates are free, but the update has some risks (as not being able to boot) should the update fail for any reason. I would not know any more than the manufacturer about your PC or the need to update the BIOS and they should be consulted about such an issue. I have updated many PC BIOS’ without a problem and without added cost, but a couple times (out of many) it failed, so doing an update must be considered seriously. In the openSUSE installer, if you are allowed to use and partition the entire disk, then there is no problem and the grub boot loader always provides a warning about disks larger than 128 GB, even when there is no problem. If I had the system working, then I would not worry about the issue any further.

Thanks for your kind words and I do spend a lot of time on-line helping others which allows me to learn more about openSUSE myself. I wish I could say the more messages, the smarter you are, but actually it is doubtful that is true. Here is some more information on forum operation you might like to know.

Get more info on forum operation here:

openSUSE Forums FAQ

Forum Message Counts:

As you start or answer any message threads here in the openSUSE forums.

Puzzled Penguin 0-49 (new users start with this level)
Student Penguin 50-99
Explorer Penguin 100-249
Busy Penguin 250-499
Parent Penguin 500-999
Wise Penguin 1000-1999
Omniscient Penguin 2000

Here is a picture of the message count symbols:

Forum Message Count Symbols

FYI here are the reputation levels:

As you reward another user for the help they have provided you using
the reputation icon is in the lower left of any message that you read
and looks like a star.

REPUTATION LEVELS:

User is infamous around these parts -99999
User can only hope to improve -50
User has a little shameless behavior in the past -10
User is an unknown quantity at this point 0-9 (new users start with this level)
User is on a distinguished road 10-19
User will become famous soon enough 20-149
User has a spectacular aura about 150-249
User is a jewel in the rough 250-349
User is just really nice 350-449
User is a glorious beacon of light 450-549
User is a name known to all 550-649
User is a splendid one to behold 650-999
User has much to be proud of 1000-1499
User has a brilliant future 1500-1999
User has a reputation beyond repute 2000

Thank You,