toubleshooting slow login

I changed from 11.3 to 12.1
Booting is OK
I see the window to login
I login username & paswd
I notice the initialization and see my personal desktop.
Everything goes fine. But after that I have to wait about 2 minutes before the OS is
reacting on a click.
How can I troubleshoot (for example going step by step)
and find out which part takes so long!
111.3 worked OK
P.S: I had a computer crash and bought a new box.
From the old HDD I could save My /home/name directory and after installing the 12.1
I copied it on the new HDD
Any suggestion is appreciated


I said it before somewhere but it might not be your problem at all.

remove the pulsaudio-files in “/etc/xdg/autostart/” they make the pulsaudio-server start a second time.
It takes a lot of time for it to realize that it already up and running… so to speak :wink:

Kind regards from me, myself and I

On 12/03/2011 02:36 AM, Middlecope wrote:
> Everything goes fine. But after that I have to wait about 2 minutes
> before the OS is
> reacting on a click.

if this is a VERY new move to 12.1 then it might be your desktop indexer
working hard to index all your stuff…or if you are using Kmail it
sure could be kmail2 trying to get caught up indexing all your
mail…so, if either of those are the case then it should get better
without you doing anything, but having the patience to let it to what it
has to do…

of course, there could be any number of other things going on…do the
logs in /var/log/ give any hint of what is causing the delay (each line
in (for example) messages has a date time stamp…so, you can zoom in
and inspect the exact time you are waiting those “two minutes”

what desktop environment are you using?

openSUSE®, the “German Engineered Automobiles” of operating systems!

I renamed the pulseaudio-kde.desktop and pulseaudio.desktop and restarted.
It made no difference
The wait time after seeinig my desktop is still 75 seconds
Thanks for the advice

The upgrade to 12.1 was 2 weeks ago.
I installed KDE
The waiting time after seeing my desktop is 75 seconds.
Do you have a hint which log file to inspect?
I see several.
Thanks for your advice

On 12/03/2011 03:46 PM, Middlecope wrote:
> Do you have a hint which log file to inspect?
> I see several.

/var/log/kdm.log (not sure about that one)

and, do this:

  1. before you log out next time open kedit (or similar) and type this
    into a new doc:

# created 03 Dec 11 to open top on the desktop at boot
# /home/[yourID]/.kde4/Autostart/sneekypeeky
xterm top

and save it to /home/[yourID]/.kde4/Autostart/sneekypeeky

then, in a terminal type and enter

chmod +x ~/.kde4/Autostart/sneekypeeky

(OR, you can use Dolphin to nav to that file and mark it executable)

  1. shut down all your open applications so that next time you start it
    won’t have a bunch to begin (in fact, that may be all you have to do:
    STOP leaving every thing running)

  2. then when you reboot it should pop up a terminal with a running
    instance of ‘top’ where you can SEE what is sucking up the
    resources…it will change every few seconds…write down the name of
    the running resource sucker as it changes…

if you are not already familiar with top: open a terminal and start it,
and learn…

once you have discovered what is taking so much horsepower you can use
Dolphin to delete (or move) sneekypeeky

openSUSE®, the “German Engineered Automobiles” of operating systems!

Don’t rename - remove them from autostart folder…

Thanks DenverD,
I tried the “sneekypeeky”
The service that is awfully busy is akonadi_agent_1
I don’t see akonadi as service in Yast-system
Can I uninstall akonadi?


I might sound very noobish and frankly I am but I somehow wonder how come all my OpenSUSE installs suffers from that slowdown before the kde4 desktop react to input. I currently have five different computers at home with OpenSUSE 12.1 -from old p4 to latest and greatest i7, Laptops and very different sound cards, etc etc.
With fresh installs they all showed this problem until I booted with a kernel debug terminal and saw that it was the pulsaudio-server that was problematic when the “pause” occurred.

Until then I blamed Anakondi/Nepomuk and whatnot as they truly used a lot of cpu but they didn’t cause the unresponsive KDE4 desktop. If you have this problem it only shows on cold starts and reboot. Logout and in again it should not be a problem.
Renaming the pulsaudio-files in “/etc/xdm/Autostart/” did not work for me I had to remove them.

My posts might sound a tad careless and nongeek but I’ve been using SuSE/OpenSUSE exclusively since version 9.0 and before that other Linux experiments.

Kind regards

On my openSUSE I found the application ‘tracker’ was slowing down the boot by an incredible amount. So I removed it, and I obtained a significant improvement in boot speed.