Totem ---- will not recognize ANY codecs.. whatsoever

Everything was fine until last night. I have reinstalled the OS and tried installing all of the codecs one by one as well as using gnome-codecs.ymp twice but to no avail. It still tells me it doesn’t have the correct codecs for ANYTHING then links to,|0.10|totem|MPEG-1%20Video%20decoder|decoder-video%2Fmpeg%2C%20systemstream%3D(boolean)false%2C%20mpegversion%3D(int)1

That is a dead link now. VLC will play some stuff but no flash.

Earlier when id try gnome-codecs.ymp id get a data stream error, but now it just does the no codecs error as though i hadn’t installed anything.

*Why this just suddenly be happening when its never happened before, and it happens even after fresh installs?

*Most importantly: What can be done to have totem work again?

vlc error doesnot support vidoe format “MSS2” - openSUSE Forums

i read that already, theres no solution there either and im not sure if it’s the same problem. VLC can play mpg fine (as can xine), but nothing can play flash aside from adobe, and totem can play nothing period. Totem worked fine for the past year until last night and now even after reinstalling its screwed.

"The playback of this movie requires the following decoders which are not installed:

MPEG-4 AAC decoder
H.264 decoder"

already installed. Every plugin it requires, already installed. Is there a specific codec folder for totem? I can’t seem to find one.

There will be soon.

It most surely is (kaffeine and xine are affected, too).

That link is for 10.3 it seems, its not supported anymore.

For totem you need to add the gstreamer plugins and the gstreamer-fluendo plugins from packman.