Totem is mute

Using SuSE 11.2 KDE. Totem is completely mute, regardless of which type of video file I try playing. Have tried Pulse and Alsa. Have tried Xine and gStreamer. Any ideas?

I’m a KDE user and not a Gnome user, and I note Totem is mostly a gnome app, … still, after some pain I was able to get Totem to work in an openSUSE-11.2 Gnome install on a sandbox PC. I did not try it on a KDE PC (there are too many good multimedia apps that work well under KDE for me to want to run Totem on a KDE PC, but thats my subjective view).

What audio/video files are you trying to play? That may or may not be important. Did you try different audio formats as opposed to only trying videos of unknown codec/formats ? i.e. .wav, .mp3 … etc …

Whose packaged gstreamer version are you using? Did you run gstreamer-properties to correctly tune the input/output modes?

Have tried mpeg1, mpeg2, divx, flv, mkv and x264 and totem remains mute. All of these play well with vlc, mplayer and xine

Audio files: wav - totem is mute, mp3 and ogg: totem crashes - segmentation fault according to the terminal.

Using Packman versions of gstreamer. Gstreamer Audio Output and Input: Autodetect, ALSA and OSS works, PulseAudio: connection refused.

I looked, but could not see your answer to this query:

Sorry if my answer was too cryptic. After reading your first answer I did run gstreamer-properties. Everything seems ok with Autodetect, ALSA and OSS, but not with PulseServer which gives an connection refused message. This applies to both output and input audio. Left the output on Autodetect (which is ALSA) and Input on ALSA. Totem is still mute.

Am afraid that totem is still mute. Any ideas?

Ideas? Yes. Dump Totem.

Use a better multimedia application. I have Totem running and I still prefer vlc and smplayer over it. Indeed even xine with its primate UI is IMHO superior.

I do prefer vlc too. Anyway I installed totem 2.28.4-1.3 from the SuSE Factory, and it works!

Great ! Thanks for sharing your solution.