Totem crashes whenever i play mp3 files

I have attached the Bug Buddy report below:-

Distribution: openSUSE 11.2 (i586)
Gnome Release: 2.28.2 (null) (SUSE)
BugBuddy Version: 2.28.0

System: Linux #1 SMP 2010-03-16 21:25:39 +0100 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10605000
Selinux: No
Accessibility: Disabled
GTK+ Theme: Sonar
Icon Theme: Sonar
GTK+ Modules: canberra-gtk-module, gnomebreakpad

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 0

Output of custom script “/usr/lib/totem/totem/”:
gst-typefind-0.10 version 0.10.24
GStreamer 0.10.29
Unknown package origin
Listened to a “application/x-id3” file on 2010-07-24T12:53:47

Why not just use Banshee (if in Gnome) or Amarok (if in KDE) to play your MP3 files? And really if you load both desktops (gnome and kde), you can play either application in either desktop. Did you know that not every program works in every desktop configuration and when you already have more than one option for playing MP3 files, I would stick with the ones that are known to work better. I don’t really know anyone that recommends Totem for playing MP3 files as a general rule. This is just my opinion of course and others may disagree.

Thank You,


Thanks for the reply,i used to use totem to play mp3 on opensuse 11.0/gnome version of totem,but the latest totem version is crashing,and i am now using banshee and gnome mplayer to play mp3,it is just that i like totem’s interface

Any help to fix the crashes would be much appreciated

Follow this
Multi-media and Restricted Format Installation Guide

But I don’t recommend Totem anyway…

@ caf4926

Installing the codecs did not help,guess there is no codec problem,the software itself may be buggy

I tried preferences for one last time while making this post and turned off the “GOOM” Visual effect and viola it works now,no more crashes,I should have guessed this sooner.The player crashed only while playing audio files and not while playing video files like avi.

Also the other visualizations are working well

Thanks all for the replies,issue resolved

Thanks for letting us know that detail, it may help others…

@ caf4926’s You are welcome.That was my intention.This is just the community atmosphere that i like with opensuse.This was absent when i was using windows.

I had the reverse - I could play mp3 in totem but banshee crashed on start.
I ended up taking the easy way and deleting all the hidden .g* files and everything worked on next login.


I have basic question about linux/openSUSE

Can we safely delete all the hidden files under our /home/<UserName> folder whose name starts with a dot or “.” without causing any complications other than losing application related setting.
Is there any chance that these files will contain any library files ?

The only real hidden user data files are te .evolution and .mozilla folders. You can safely delete all the .g* files and folders relating to gnome without a problem. All that happens is that the next time you login a new set of default files is loaded.

@whych -Thanks for the clarification

Thanks, it works me too!