Toshiba Satellite screen flickering after sleep

Hi!

I have a Toshiba Satellite R850-153 with dual boot OpenSuse 12.1, KDE 4.7.2 and Windows 7. The graphic card is ATI Radeon. My problem occurs only if I turned on the computer unplugged and then plugged it in after a while.

The scenario goes like this: I turn on the computer and notice I forgot to plug in the AC adapter. I plug in the adapter and everything works fine. After a while I get out of the room to fetch myself something to drink and when I return, I notice the screen is black. It shouldn’t be, since I disabled the Dim Display and Screen Energy Saving option. When I move the mouse, the screen turns on but flickers violently. It gets bearable when I turn down the brightness, but in that case I’m almost unable to read since the screen is so dark. The flickering gets better after a while and almost disappears after a few hours.

The worst thing is that the problem doesn’t solve even if I reboot the computer. The screen flickers in the boot menu already. The strange thing is, that this never happened in Windows, although it is true I don’t use it very often.

I did some googling but found nothing similar.

Thank you for helping me,
Martin

On 06/14/2012 02:26 PM, potlehar wrote:
> since I disabled the Dim Display and Screen Energy Saving option.

you disabled those where? in the BIOS or KDE configure desktop > power
management > power profiles ??

if the latter, did you disable it for all power conditions (plugged in
or not, and low charge or not)??

i’d say begin by looking over those settings…

the flickering you speak of…i wonder if yours has an automatic screen
dimmer/brighter (based on a sensor checking ambient lighting)…if so,
maybe that is acting up…

you might try booting up with one or the other (or even both) of these
typed into the “Boot Options” line on the first green boot screen


acpi_osi=Linux
acpi_backlight=vendor

neither may do any good, and i highly doubt either could be
harmful…but, just in case read here before proceeding:
http://tinyurl.com/DD-Caveat


dd

Thanks dd!

The ‘acpi_osi=Linux’ solved my problems. I edited the power management settings in KDE configure desktop, but obviously they were overridden by something else. Now the computer behaves as set in ‘configure desktop’ and there is no flickering.

Thank you!

On 06/15/2012 02:46 PM, potlehar wrote:
> Thank you!

welcome! thanks for reporting your success (which will very likely help
the next Toshiba Satellite user who googles in!!)

note: the power settings you set were probably being overridden by the
acpi stuff…i guess KDE and acpi were fighting for control…causing
the flicker back and forth…

thought provoking stuff here: http://en.wikipedia.org/wiki/Acpi


dd