Toshiba laptop with openSUSE11.2: wrong screen resolution

Hi everyone,
First-timer here but I’ve been using Ubuntu casually for a few months. Just installed openSUSE 11.2 GNOME on my Toshiba Satellite Pro 4600 P3 laptop that recently has WinXP Pro and Ubuntu Karmic Koala. The video card is Trident Cyberblade XP and the video chipset is Intel 82815. How do I copy the two driver files, called “” and “” from Ubuntu into where in openSUSE, and how do I actually make changes to /etc/sysconfig/displaymanager so that the current screen resolution 1024x768 in Ubuntu is repeated in openSUSE? As it is right now, the resolution is only 800x600 because I just installed openSUSE?

Thanks a lot for your help.

That is not recommended.

Thats not the place to do this in openSUSE.

Here is some practical information on the openSUSE structure for this. openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

I hope this helps.

(ie boot direct to run level 3, do not go there via init 3 from run level 5, and then login as a regular user, switch to root permissions, and run sax2 with appropriate arguments). Or if there is already an /etc/X11/xorg.conf file present, try renaming it to something else, and then boot with no xorg.conf and see what happens.

Hello oldcpu,

I went to the link you gave entitled “openSUSE Graphic Card Practical Theory Guide for Users” but I did not see where I can set screen resolution, screen refresh rate, horizontal and vertical frequencies,etc. for the graphic card. Am I overlooking something? Could you show me how?

Thanks a lot for your help.

Hello again, oldcpu,
Ok. I just did boot to run level 3 and forced sax2 to create an xorg.cof file for either the ati or intel driver. Here’s what the screen shows:

sax2 -r -m 0=ati (2nd round: 0=intel)

Sax: no X-server is running
Sax: will start own server if needed
ISax: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199
SPP: prepare device (0) profile: nobus
SPP: including prepared profiles
Sax: startup

xc: sorry could not start configuration server
xc: for details refer to the log file: /var/log/Sax.log
xc: abort (this is what I typed to get back to the command prompt below)

I should also point out that at the bottom of the GRUB screen there’s a window showing: “Boot option” “vesa=0x317”

Does this boot option (vesa=0x317) give any useful information? I also noted that in Ubuntu Karmic Koala VGA=791(current resolution 1024x768).

I trust the above is helpful,and I would appreciate hearing from you.


Another correction:

Boot option: VGA (not vesa) = 0x317

I confess this puzzles me:

ie typically one uses a trident driver or an intel driver, but not both.

What does

sax2 -p 

give ? It will tell us what sax2 thinks your card graphics are.

OK, so that is useful. You know know the basic ati driver and intel driver do not work. Possible they will work with additional tuning.

Why did you try the “ati” driver? Is that because you believe trident associated with ati ?

Did you try the VESA driver ? ie

sax2 -r -m 0=vesa

Note also, there are many options for sax2. If with root permissions you type:

man sax2

you will see the many options.

There is also a trident driver that comes with the xorg-x11-driver-video rpm. If you type:

man trident

you will read some information on that.

And of course an option for configuring a trident driver is:

sax2 -r -m 0=trident

I confess the other information you provided is not useful to me, given the limitations of my knowledge on this subject.

One cn determine what drivers are inside the rpm xorg-x11-driver-video, and I provided an indication on how to do that both in the later posts in here openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums and I also put that information in a wiki HCL/All Video Cards - openSUSE .

I hope that helps.

Note starting tomorrow, I will be away for 2 weeks and likely not able to access the forum.

Hello oldcpu,

OK. Here’s my reply to you in the same sequence as in your message:

  1. My mistake. Intel 82815 is not a video chipset, it’s probably part of the Intel Pentium III chipset.

  2. sax2 -p gives:
    Chip: 0 is Trident 9910 01:00:00 0x1023 0x9910 AGP Trident

3.I just tried: sax2 -r -m 0=trident
Sax: No X-server is running
Sax: will start own server if needed
ISax: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199

Sax starts up
Current configurationis suggested by sax2: OK if accept


Sax2:X11 configuration

Card and Monitor Properties


Card: Trident 9910 Options
Monitor: LCD 1024x768 @60Hz Change

I then hit the CHANGE button to change refresh rate from 60 to 70 Hz

Resolution: 1024x768 (XGA)
Color: 65536 (16 bit)

I chose OK. Then I selected TEST to test the revised config
Screen looks full (OK) so I hit SAVE

#shutdown -r now


Voila! I solved the problem and now get my 1024x768 resolution back!

Thank you very much for your help. This is way easier than the Ubuntu way which involves editing xorg.conf file, and I often had to do this when upgrading to a new Ubuntu version because of kernel changes.

How do I mark this thread as SOLVED?

Congratulations on solving this and thankyou for sharing your solution.

We typically do not mark the Title as “SOLVED” as unfortunately the title is used by NNTP users to organize threads, and if we change the thread title it will break things for NNTP users. So instead let me just say:
**SOLVED ! **