Toshiba L735-13V Some FN keys works only after sleeping/waiting mode

Hello all,
On my toshiba L735 backlight+wifi fn keys not working.
I found this in dmesg:
98.988660] atkbd serio0: Unknown key pressed (translated set 2, code 0x55 on isa0060/serio0).
98.988670] atkbd serio0: Use ‘setkeycodes 55 <keycode>’ to make it known.
100.646843] atkbd serio0: Unknown key pressed (translated set 2, code 0xee on isa0060/serio0).
100.646853] atkbd serio0: Use ‘setkeycodes e06e <keycode>’ to make it known.
103.921317] atkbd serio0: Unknown key released (translated set 2, code 0xd4 on isa0060/serio0).
103.921327] atkbd serio0: Use ‘setkeycodes e054 <keycode>’ to make it known.

I tried setkeycodes, but all I got is only showing gnome3 icons of change backlight, not real change. (in kde, same effect)
Also i checked /sys/class/backlight/toshiba, brightness value changed, but have no effect.

And I found out when I switch the laptop into sleeping(or waiting) mode, resume from it, all keys work! i checked it again, and they all worked!
I make diff of lsmod output before and after hibernate, they were the same.

System: openSUSE 12.1 and kernel 3.3 from Tumbleweed (it’s necessary for cardreader work)

In what may be the problem? And how can this be with hibernate?